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คํานํา 

 ตามที่ สํานักงานปลัดกระทรวงสาธารณสุข โดยสํานักนโยบายและยุทธศาสตร์        
ได้ดําเนินการจัดอบรม “การให้รหัส และการประเมินตรวจสอบคุณภาพการให้รหัสโรคและรหัส
หัตถการ สําหรับผู้รับผิดชอบ Data Center ระดับจังหวัด และเขตเครือข่ายบริการสุขภาพ” เป็นราย
ภาค โดยมีวัตถุประสงค์ 1) เพ่ือให้เจ้าหน้าที่ที่รับผิดชอบงานข้อมูลสุขภาพในระดับจังหวัดและเขต
เครือข่ายบริการ มีความรู้ความเข้าใจ แนวทางการบันทึกข้อมูลบริการ คําวินิจฉัยโรคและการให้รหัส
โรค และการมารับบริการสุขภาพ ได้อย่างถูกต้อง และครบถ้วน เป็นมาตรฐานเดียวกัน 2) มีความรู้
ความเข้าใจ แนวทางการตรวจสอบคุณภาพการให้รหัสโรค และหัตถการในหน่วยบริการในเขต
รับผิดชอบได้ และ 3) เพ่ือให้ข้อมูลการให้รหัสโรค รหัสหัตถการและการบันทึกข้อมูลตามแฟ้มโครงสร้าง
มาตรฐานใน Health Data Centre มีความถูกต้อง มีคุณภาพตรงตามมาตรฐาน  เสร็จเรียบร้อยไปแล้ว
ต้ังแต่เดือนเมษายน 2558 ที่ผ่านมาน้ัน 
  จากการดําเนินการดังกล่าว สํานักนโยบายและยุทธศาสตร์ได้คํานึงถึงภาระงานที่จะ
เพ่ิมขึ้นในระดับจังหวัดและเขตเครือข่ายบริการสุขภาพ และเป็นภารกิจที่ต้องดําเนินการต่อเน่ืองจาก
การอบรมดังกล่าวข้างต้น และประเด็นที่สําคัญคือ หน่วยงานที่รับผิดชอบ Health Data Centre ใน
ระดับจังหวัดต้องการแนวทาง หรือ เครื่องมือในการวิเคราะห์คุณภาพข้อมูลดังกล่าว เพ่ือทราบ
สถานการณ์คุณภาพข้อมูลและสถานะสุขภาพในเขตพื้นที่ความรับผิดชอบของตนเองได้ จึงดําเนิน
โครงการอบรมการวิเคราะห์และนําเสนอผลการวิเคราะห์คุณภาพข้อมูลการให้รหัสโรค (ICD-10-TM) 
ในคลังข้อมูลสุขภาพ (Health Data Centre) ให้ใช้เป็นแนวทาง เครื่องมือตรวจ กรอง และวิเคราะห์
คุณภาพข้อมูลการให้รหัส ที่เป็นประเด็น กฎเกณฑ์ต่างๆ ให้เป็นมาตรฐานเดียวกันทั้งประเทศ ซึ่งจะทํา
ให้ลดภาระงานดังกล่าวได้มาก โดยการวิเคราะห์คุณภาพข้อมูลการให้รหัสโรคน้ี จะมีขั้นตอนที่สําคัญ 
ดังน้ี 

1. การทําให้ข้อมูลมองเห็นได้ (Data Visualization) 
2. การใช้การคํานวณเพ่ือวิเคราะห์ความหมายด้านต่างๆของข้อมูล 
3. การนําเสนอข้อมูลที่วิเคราะห์แล้วในรูปแบบสารสนเทศ เพ่ือนําไปใช้ประโยชน์ เช่น 

การเปรียบเทียบข้อมูลสุขภาพเป็นรายอําเภอ รายจังหวัด รายเขตเครือข่ายบริการสุภาพ หรือ กลุ่มโรค
หลักที่ผู้ป่วยเป็นมากที่สุด เป็นต้น 

 สํานักนโยบายและยุทธศาสตร์ จึงจัดทําคู่มือการสร้างคลังข้อมูลเพ่ือการวิเคราะห์
คุณภาพการให้รหัส ICD ในคลังข้อมูลสุขภาพ / สถานพยาบาล เพ่ือใช้เป็นคู่มือประกอบการดําเนินการ
ในการวิเคราะห์การให้รหัส ICD ดังกล่าว 

 
 

    สํานักนโยบายและยุทธศาสตร์ 
มิถุนายน 2558 
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บทท่ี 1   

บทนําสูการสรางคลังขอมูลและการวิเคราะหขอมูลโรงพยาบาลเพื่อคนหาโอกาส

การพัฒนา 
 

การวิเคราะหขอมูลในโรงพยาบาลเปนส่ิงที่ทําไดงายขึ้นในปจจุบันเพราะเราสามารถใชเทคโนโลยีสารสนเทศ

ชวยในการวิเคราะหขอมูลไดอยางสะดวก รวดเร็วกวาในอดีต อยางไรก็ตาม โรงพยาบาลหลายแหงยังไมไดวิเคราะหขอมูล

ในระบบคอมพิวเตอรของโรงพยาบาลอยางเต็มที่ บางแหงจัดทําเพียงสถิติทั่วๆไป ไมไดนําขอมูลมาพัฒนาใหเกิดองค

ความรูที่จะใชพัฒนาโรงพยาบาลตอไป 

 ขอมูลในระบบคอมพิวเตอรของโรงพยาบาลแตละแหงกําลังเพิ่มขึ้นอยางตอเน่ือง เพราะโรงพยาบาลสวนใหญ

ในประเทศไทยไดนําระบบคอมพิวเตอรมาใชจัดการขอมูลการดําเนินงานมานานนับสิบป ระบบจัดเก็บขอมูลในปจจุบัน

สามารถจัดเก็บขอมูลปริมาณมากมายมหาศาลโดยที่มีราคาถูกลงเรื่อยๆ ระบบการคิดคํานวณของหนวยประมวลผลก็

สามารถคํานวณไดอยางรวดเร็วมากและมีราคาถูกลงเชนกัน และโปรแกรมที่ใชวิเคราะหขอมูลที่ออกมาใหมจํานวนมากก็

เปนโปรแกรมที่มีความสามารถสูงและราคาต่ําหรือเปนโปรแกรมที่ใหใชงานฟรี ปจจัยเหลาน้ีทําใหการวิเคราะหขอมูลใน

ระบบคอมพิวเตอรของโรงพยาบาลสามารถสกัดขอมูลที่ตองการไดอยางมากมาย ภายในเวลาไมนาน จึงควรวิเคราะห

ขอมูลอยางสมํ่าเสมอในแงมุมตางๆ เพื่อชวยการตัดสินใจใหมีประสิทธิภาพ และหาโอกาสการพัฒนา 

 
ลักษณะทั่วไปของขอมูล 

 ขอมูล คือ ขอเท็จจริง ที่เกิดขึ้นจากเหตุการณตางๆ และมาจากการจดบันทึกของคน หรือบันทึกดวยระบบ

อัตโนมัติ มนุษยจะรับขอมูลจากเหตุการณตางๆดวยการสังเกต การนับ การวัด การซักถามผูอ่ืน แลวบันทึกโดยการจดจํา 

หรือเขียนลงในส่ือที่ใชบันทึกขอมูล ในปจจุบัน มนุษยไดสรางระบบที่สามารถชวยนับ วัด จับภาพ จับเสียง แลวบันทึกลง

ส่ือบันทึกขอมูลโดยอัตโนมัติ ทําใหเรามีขอมูลมากมายที่สามารถเลือกมาใชประโยชนได 

 เราสามารถจําแนกขอมูลทั่วไปไดเปน 2 ประเภท [1] คือ ขอมูลที่ใชคํานวณได และขอมูลที่ใชคํานวณไมได 

โดยขอมูลที่ใชคํานวณได ตองเปนขอมูลแบบตัวเลข (Numeric) สวนขอมูลที่ใชคํานวณไมไดอาจเปนตัวเลข เปน

ขอความ เปนภาพ เสียง หรือส่ือผสม ก็ได 

 ขอมูลที่ใชคํานวณได ตองเปนแบบตัวเลข เพื่อใหสามารถนําไป บวก ลบ คูณ หาร ได สวนขอมูลที่คํานวณไมได 

มี 2 ลักษณะ คือ ขอมูลที่เปนขอความ เปนเสียง ภาพ ส่ือผสม ที่ไมสามารถนําไปบวก ลบ คูณ หาร ได กับขอมูลที่เปน

ตัวเลข แตไมสมควรนําไปคํานวณ เชน เลขรหัสประจําตัวประชาชน หมายเลขโทรศัพท 

 

การวิเคราะหขอมูล 

 การวิเคราะหขอมูล หมายถึง การจําแนกแยกแยะเน้ือหาในขอมูล เพื่อคนหาวาขอมูลมีลักษณะเปนอยางไร มี

องคประกอบยอยๆอะไรบาง ประกอบกันขึ้นมาไดอยางไร และมีความสัมพันธเชื่อมโยงกันอยางไร 

 กอนยุคเทคโนโลยีสารสนเทศ มนุษยใชสมองเปนเครื่องมือหลักในการวิเคราะหขอมูล โดยมีเครื่องมือรอง ไดแก 

ลูกคิดหรือเครื่องชวยคํานวณรูปแบบตางๆ บันทึกลักษณะขอมูลเดิมเพื่อใชเปรียบเทียบ การวิเคราะหขอมูลของมนุษย

สามารถใชวิเคราะหขอมูลไดทุกแบบ ทั้งขอมูลที่ใชคํานวณได และขอมูลที่ใชคํานวณไมได แตความรวดเร ็วในการ

วิเคราะหขอมูลของมนุษยคงจะสูความรวดเร็วของเทคโนโลยีสารสนเทศไมด 



2 
 

 ในยุคปจจุบัน เราสามารถใชเทคโนโลยีสารสนเทศชวยวิเคราะหขอมูล ทําใหเรามีทางเลือก 2 แบบในการ

วิเคราะหขอมูล อยางไรก็ตาม การใชเทคโนโลยีสารสนเทศจะชวยใหสามารถวิเคราะหขอมูลประเภทที่ใชคํานวณไดอยาง

รวดเร็วกวาเดิมหลายเทา แตการใชเทคโนโลยีสารสนเทศจะมีขอจํากัดในการวิเคราะหขอมูลประเภทที่ใชคํานวณไมได 

ดังเชน เราสามารถใชโปรแกรมคอมพิวเตอรคํานวณคาเฉล่ียรายไดของคน 1 ลานคน ไดในเวลาชั่วพริบตา แตเราไม

สามารถใชโปรแกรมคอมพิวเตอรใดๆ วิเคราะหบทสัมภาษณบุคคลใด แลวสรุปความเชื่อ ทัศนคติ ของบุคคลน้ันออกมา

ได เพราะขอมูลในบทสัมภาษณเปนขอมูลประเภทที่ใชคํานวณไมได ตองใชมนุษยเปนผูวิเคราะหเทาน้ัน 

 อยางไรก็ตาม เรายังสามารถใชโปรแกรมคอมพิวเตอรชวยวิเคราะหขอมูลประเภทที่ใชคํานวณไมได แตตองมี

การจัดเตรียมขอมูลใหเหมาะสม โดยตองแปลงขอมูลที่ตองการวิเคราะหใหเปนตัวเลข เชน ขอมูลเพศ ตองกําหนดใหเพศ

ชายเปนเลข 1 เพศหญิงเปนเลข 2 หรือ ขอมูลระดับการศึกษา กําหนดให ระดับต่ํากวาปริญญาเปน เลข 1 ปริญญาตรี

หรือโท เปนเลข 2 ปริญญาเอกเปนเลข 3 เปนตน 

 เรายังสามารถโปรแกรมคอมพิวเตอรขั้นสูงวิเคราะหขอมูลประเภทที่ใชคํานวณไมได โดยอาศัยอัลกอริธึมที่

สลับซับซอน เชน เราสามารถวิเคราะหบทสัมภาษณบุคคล โดย Natural language processing algorithm 

หรือ สามารถวิเคราะหภาพโดยใช Image processing algorithm ได แตในตําราเลมน้ี จะไมครอบคลุมเน้ือหา

เหลาน้ัน 

 

ลักษณะขอมูลที่เหมาะสมกับการวิเคราะหดวยคอมพิวเตอร 
 ขอมูลที่เราจะใชโปรแกรมคอมพิวเตอรชวยวิเคราะหควรจะเปนตัวเลข โดยขอมูลที่เปนตัวเลขอยูแลว เราไม

ตองจัดเตรียมอะไรเพิ่มเติม นอกจากกํากับไววาเปนตัวเลขที่จะนําไปคํานวณหรือไม (ขอมูลที่เปนตัวเลขบางตัวไมควร

นําไปคํานวณ เชน เลขประจําตัวประชาชน) สําหรับขอมูลที่ยังไมเปนตัวเลข จะตองนําไปจัดกลุม กําหนดเลขของแตละ

กลุมออกมา แลวเปล่ียนขอมูลใหกลายเปนตัวเลขตามกลุม ก็จะนําไปวิเคราะหดวยโปรแกรมได 

 การแปลงขอมูลที่ยังไมเปนตัวเลขใหกลายเปนตัวเลข จะทําใหขอมูลมีลักษณะที่สามารถจําแนกความแตกตาง

ระหวางกลุมได อยางไรก็ตาม ขอมูลเหลาน้ีอาจมีลักษณะที่แตกตางกันเปน 4 แบบ ดังน้ี 

1. ขอมูลระดับนามบัญญัติ (Nominal scale) มีลักษณะการจําแนกเปนกลุม เปนพวก เทาน้ัน ไมสามารถ

บอกความแตกตางระหวางกลุมได เชน กําหนดให 1 แทน เพศชาย 2 แทนเพศหญิง ไมไดหมายความวาหญิงมีลักษณะ 

มากกวา ชาย เทากับ 2-1 = 1 ดังน้ัน ขอมูลแบบน้ีจึงนําไป บวก ลบ คูณ หารกันไมได ทําไดเพียงแค นับ แลวหาคา

สัดสวนเปนรอยละ เชน คํานวณวามีชายและหญิงรอยละเทาไรเพียงเทาน้ัน 

2. ขอมูลระดับเรียงอันดับ (Ordinal scale) มีลักษณะการจําแนกเปนกลุม เชนเดียวกับขอมูลนามบัญญัติ 

แตสามารถบอกความแตกตางของกลุมไดอยางคราวๆ เชน ระดับความพึงพอใจ 1 แทน นอยที่สุด 2 แทน นอย 3 แทน

ปานกลาง 4 แทนมาก 5 แทนมากที่สุด เราสามารถดูขอมูลแลวบอกไดวา ความพึงพอใจเปนแบบใด และยังบอกไดวา 

ระดับ 5 มากกวาระดับ 2 อยู 3 ระดับ ดวย ดังน้ัน ขอมูลแบบน้ี เราสามารถนําไปนับ หาคาสัดสวนเปนรอยละ และ

นําไป ลบกันเพื่อหาระดับความแตกตางไดดวย 

3. ขอมูลระดับชวง (Interval scale) มีลักษณะการจําแนกเปนชวง สามารถบอกความแตกตางของแตละ

ชวงได เชน ขอมูลเกรดของนักศึกษา เราสามารถบอกไดวา เกรด 4 สูงกวา เกรด 2 อยางไรก็ตาม เกณฑการใหเกรดใน

แตละสถาบันอาจแตกตางกันไป ทําใหไมสามารถคํานวณเกรดนักศึกษาตางสถาบันรวมกันได แตยังถือวา ขอมูลระดับชวง

น้ี นําไปคํานวณไดมากกวาขอมูลระดับเรียงลําดับและนามบัญญัต ิ
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4. ขอมูลระดับอัตราสวน (Ratio scale) มีลักษณะที่สามารถจําแนกกลุมและบอกความแตกตางระหวาง

กลุมเปนตัวเลขไดอยางสมบูรณแบบ มีจุดเริ่มตนคงที่ เชน เริ่มที่ 0 ตัวอยางของขอมูลประเภทน้ี ไดแก นํ้าหนัก สวนสูง 

คะแนนสอบ ฯลฯ เราสามารถนําขอมูลลักษณะน้ีไปคํานวณไดทุกรูปแบบ 

 
ขอมูลทั้ง 4 ระดับ อาจจัดรวมเปน 2 กลุม คือ ขอมูลคุณภาพ (Quantitative data) ประกอบดวย ขอมูล

ระดับ นามบัญญัติ และ เรียงอันดับ และขอมูลปริมาณ (Qualitative data) ประกอบดวย ขอมูลระดับ ชวง และ 

อัตราสวน 

 

ลักษณะของขอมูลในระบบโรงพยาบาล 

 ขอมูลในระบบโรงพยาบาล จะมีลักษณะเฉพาะไมเหมือนขอมูลอ่ืนทั่วไป เพราะในโรงพยาบาลมีขอมูลที่

แตกตาง 6 กลุม ตามลักษณะกลุมโครงสรางของระบบโรงพยาบาล [2] ดังน้ี  

1. ขอมูลผูปวย เปนขอมูลระบุตัวผูปวย ลักษณะทางประชากรศาสตร สถานภาพสมรส สิทธิการรักษา ที่อยู 

ฯลฯ ขอมูลเหลาน้ีจะเปล่ียนแปลงเม่ือผูปวยยายที่อยู เปล่ียนที่ทํางาน แตงงาน มีลูก ตามกิจกรรมของผูปวย เจาหนาที่

เวชระเบียนควรหม่ันปรับปรุงขอมูลผูปวยใหทันสมัยโดยขอขอมูลเพิ่มเติมเปนระยะ 

2. ขอมูลกิจกรรมการบริการผูปวย  เปนขอมูลที่มีมากที่สุดในทุกโรงพยาบาล เก็บรายละเอียดการบริการ

ผูปวยทุกครั้ง ไดแก ขอมูลการมาตรวจ การจายยา คารักษา ผลการตรวจทางหองปฏิบัติการ ฯลฯ ผูบันทึกขอมูลคือผูที่

ดูแลผูปวยทุกคน ตั้งแต แพทย พยาบาล เภสัชกร เจาหนาที่หอง Lab เจาหนาที่การเงิน ฯลฯ  

3. ขอมูลทรัพยากร เปน ขอมูลการจัดสรรทรัพยากรในการรักษาพยาบาลผูปวย ไดแก ขอมูลตารางนัด ตาราง

การผาตัด จํานวนเตียงวาง รายการยาที่มีในโรงพยาบาล จํานวนแพทยสาขาตางๆ ฯลฯ ขอมูลลักษณะน้ีจะมีผูบันทึก

ขอมูลเพียงไมก่ีคน แตมีผูใชขอมูลจํานวนมากที่ตองเรียกดูขอมูลเหลาน้ีอยูบอยๆ 

4. ขอมูลทางคลินิก เปนขอมูลที่ชวยใหแพทย พยาบาล และเจาหนาที่ที่บําบัดรักษาผูปวยโดยตรงตองใช

เพื่อใหการดูแลรักษาอยางตอเน่ืองมีคุณภาพที่ดี ไดแก ประวัติการเจ็บปวย ผลการตรวจรางกาย การวินิจฉัย รายงานการ

ผาตัด การใหการพยาบาล บันทึกทางกายภาพบําบัด ฯลฯ ขอมูลลักษณะน้ี ใชเพื่อส่ือสารระหวางแพทย พยาบาล และผู

มีหนาที่บําบัดรักษาผูปวย เพื่อใหรายละเอียดชวยการตัดสินใจที่ด ี

5. ขอมูลการบริหาร เปนขอมูลเพื่อชวยใหการบริหารโรงพยาบาลเปนไปอยางมีประสิทธิภาพ ไดแก ขอมูล

ตนทุนคายา คารักษาตางๆ ขอมูล username, password ขอมูลการปวย ลา ขาด สายของบุคลากร ฯลฯ ขอมูล

ลักษณะน้ีอาจไดมาจากการบันทึก หรือไดจากการคํานวณขอมูลอ่ืนๆประกอบกัน 

6. ขอมูลอางอิง เปนขอมูลที่ใชเรียกดูประกอบการตัดสินใจ ไดแก ตารางยาที่ออกฤทธ์ิรบกวนกัน รายการยาที่

เบิกคารักษาได รายการคารักษาที่เบิกได หรือ เบิกไมได ฯลฯ ขอมูลน้ีสวนใหญมาจากองคกรภายนอกของโรงพยาบาล 

ผูดูแลระบบจะเปนผูรับผิดชอบใหขอมูลกลุมน้ีทันสมัยอยูเสมอ 

ขอมูลที่ควรนํามาใชวิเคราะหเปนระยะไดแก ขอมูลกลุมที่ 1 ผูปวย 2 กิจกรรม 3 ทรัพยากร และ 5 บริหาร 

เพื่อใหรูวาลักษณะผูมารับบริการเปนกลุมไหน กิจกรรมและการใชทรัพยากรเปนอยางไร ควรบริหารอยางไรใหมี

ประสิทธิภาพ 
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การวิเคราะหขอมูลผูปวย 

ขอมูลผูปวย เปนขอมูลที่สําคัญเพราะผูปวยเปนผูมารับบริการรักษาพยาบาล หากเราเขาใจลักษณะของผูมารับ

บริการเปนอยางดี เรายอมสามารถปรับบริการของโรงพยาบาลใหสอดคลองกับผูปวย เพิ่มความสะดวกสบายและความ

พึงพอใจของผูปวยได ผูปวยและญาติก็จะเกิดความรูสึกที่ประทับใจ ลดโอกาสรองเรียนได ตัวอยางการวิเคราะหขอมูล

ผูปวยไดแก 

- สัดสวน เพศ อายุ ภูมิลําเนา เชื้อชาติ สัญชาติ ของผูปวย 

- สัดสวนสถานภาพสมรส อาชีพ สถานที่ทํางาน 

- สัดสวน สิทธิการรักษาของผูปวย เรียงตามลําดับที่มีสัดสวนมากไปนอย 

- กลุมโรคหลักที่ผูปวยเปนมากที่สุด 30 อันดับแรก 

- โรคประจําตัวที่ผูปวยเปนมากที่สุด 10 อันดับแรก 

- การผาตัดที่ผูปวยไดรับกันมากที่สุด 20 อันดับแรก 

- แนวโนมการเปล่ียนแปลงลักษณะผูปวยในรอบ 6 เดือน 1 ป 3 ป 5 ป 

 

การวิเคราะหขอมูลกิจกรรมการรักษาพยาบาล 

ขอมูลกิจกรรม เปนขอมูลที่มีมากที่สุดในระบบคอมพิวเตอรโรงพยาบาล เพราะเราใชคอมพิวเตอรบันทึกขอมูล

กิจกรรมเหลาน้ีตลอดเวลา เริ่มจากจุดยื่นบัตร ไปจนพบพยาบาล พบแพทย ตรวจ Lab X-Rays จายยา จายเงิน จน

ผูปวยกลับบาน จึงเปนขอมูลที่วิเคราะหไดมากที่สุด ตัวอยางการวิเคราะหขอมูลกิจกรรม ไดแก 

- จํานวนผูปวยที่มารับบริการตาม OPD หรือจุดบริการตางๆ 

- จํานวน และสัดสวนการตรวจทางหองปฏิบัติการ การตรวจพิเศษ การตรวจทางรังสีวิทยา 

- คาใชจายเพื่อบริการตางๆ เชน คายา คาตรวจทางหองปฏิบัติการ คาตรวจพิเศษ 

- ระยะเวลาที่รอคิว ระยะเวลาที่ใหบริการในจุดตางๆ  

- จํานวน และ สัดสวนการใหบริการจําแนกตามแพทย พยาบาล บุคลากรอ่ืนๆ 

- จํานวนและสัดสวนผูปวยที่มาตรวจตามนัด และไมมาตามนัด 

- แนวโนมการเปล่ียนแปลงจํานวน และสัดสวนการใหบริการ ในรอบ 6 เดือน 1 ป 3 ป 5 ป 

 

การวิเคราะหขอมูลทรัพยากร 
เราควรวิเคราะหจํานวน และการจัดสรรทรัพยากรดานบุคคล สถานที่และวัสดุอุปกรณรวมทั้งยา ในกิจกรรม

ของโรงพยาบาลทุกๆกิจกรรม เพื่อใหสามารถบริหารทรัพยากรใหมีประสิทธิภาพมากที่สุด เพราะทรัพยากรทุกดานมี

จํากัด หากไมวิเคราะหขอมูลใหดี ก็อาจไมรูวากําลังใชทรัพยากรบางอยางโดยสูญเปลา ตัวอยางการวิเคราะหขอมูล

ทรัพยากร ไดแก 

- จํานวน และสัดสวน แพทย พยาบาล เภสัชกร และบุคลากรอ่ืนๆ 

- จํานวน และสัดสวนยา เวชภัณฑ นํ้ายา วัสดุตางๆที่ใช รวมถึงการส่ังซ้ือและจัดเก็บ 

- จํานวนหองตรวจ จํานวนเตียงผูปวย จํานวนหองผาตัด อัตราการครองเตียง 

- เวลาที่ใชในการตรวจ การผาตัด การเจาะเลือด การตรวจเอ็กซเรย 
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- เวลาที่วางในตารางนัดตรวจ คิวนัด การจัดสัดสวนการนัด 

- จํานวนและสัดสวนการสูญเสียทรัพยากรดานตางๆ เชน เวลาที่ผูปวยไมมาตามนัด 

- แนวโนมการเปล่ียนแปลงจํานวน และสัดสวนการใชทรัพยากรตางๆ ในรอบ 6 เดือน 1 ป 3 ป 5 ป 

 

การวิเคราะหขอมูลการบริหาร 
ผูบริหารโรงพยาบาล ตองมีขอมูลที่ดีเพื่อชวยในการคิดและการตัดสินใจ โดยตองเปนขอมูลที่ถูกตอง เชื่อถือได 

และทันสมัย ขอมูลสนับสนุนการบริหารมักเปนขอมูลที่ตองวิเคราะหไวลวงหนา จึงควรคิดวิธีการวิเคราะหไวกอนที่

ผูบริหารจะเรียกใช เพื่อใหไดขอมูลทันตามที่ผูบริหารตองการ ตัวอยางการวิเคราะหขอมูลการบริหารไดแก 

- ตนทุนการรักษาผูปวยนอก ผูปวยใน ตนทุนรายโรค 

- คาใชจายในการซ้ือยา วัสดุ อุปกรณ คาสาธารณูปโภค 

- รายรับ และรายไดตางๆของโรงพยาบาล 

- จํานวนและสัดสวนคนทํางานตามจุดตางๆ การจัดเวร  

- อัตราการลาออกของแพทย พยาบาล บุคลากรตางๆ 

- ผลการดําเนินการตามตัวชี้วัดตางๆ 

- แนวโนมการเปล่ียนแปลงลักษณะขอมูลบริหาร ในรอบ 6 เดือน 1 ป 3 ป 5 ป 

 

  



6 
 

บทที่ 2 
การจัดเตรียม ตรวจสอบ และแกไขคุณภาพขอมูลกอนนําเขาคลังขอมูล 
 

คลังขอมูลจะตองเปนแหลงขอมูลที่ถูกตอง แมนยําและเชื่อถือได ดังน้ัน ขั้นตอนที่สําคัญกอนสรางคลังขอมูล 

คือการจัดเตรียม ตรวจสอบและแกไขคุณภาพขอมูลกอนนําเขาคลังขอมูล โดยผูสรางคลังขอมูลจะตองจัดเตรียมขอมูลมี

ลักษณะรูปแบบฐานขอมูลที่เหมาะสม หรือถาดึงขอมูลออกมาจากระบบฐานขอมูลขององคกรก็จะตองตรวจสอบขอมูลที่

ดึงออกมาวาลักษณะที่เหมาะสมหรือไม หากพอวาขอมูลที่ลักษณะที่ไมเหมาะสม ก็ตองลงมือแกไขขอมูลใหมีลักษณะที่

เหมาะสมกอนนําเขาคลังขอมูล 

 การจัดเตรียมและตรวจสอบขอมูลใหอยูในลักษณะที่เหมาะสม อาจกลาวไดวาเปนการตรวจลักษณะขอมูลให

อยูรูปแบบฐานขอมูลที่เหมาะสมน่ันเอง 

 

ลักษณะขอมูลในรูปแบบฐานขอมูลที่เหมาะสม 
 ขอมูลที่จัดเก็บในรูปแบบฐานขอมูลที่ดี จะตองมีลักษณะดังตอไปน้ี 

1. เปนขอมูลที่อยูในรูปแบบตาราง โดยตารางน้ีจะตองมีบรรทัดแรกสุดเปนคําบรรยายลักษณะของขอมูลที่เก็บ

ไวในแตละชอง พื้นที่เหนือตารางตองไมเปนแถววางหรือมีคําบรรยายใดๆอยูเหน่ือแถวที่เปนคําบรรยาย

ลักษณะขอมูล 

2. ขอมูลในแถวที่อยูถัดจากบรรทัดแรกลงมาทั้งหมดเปนขอมูลแตละรายการ โดยตองไมมีบรรทัดวางแทรกอยู

ในรายการเหลาน้ี 

3. ตารางขอมูลในแตละชองควรเก็บขอมูลแตละเรื่องแยกออกจากกัน เชน แยกขอมูล คํานําหนาเก็บไวชองแรก 

ชื่อเก็บไวในชองที่ 2 และนามสกุลเก็บไวในชองที่ 3 ไมควรเก็บคํานําหนา ชื่อ นามสกุลไวในชองเดียวกัน 

4. คําบรรยายลักษณะขอมูลแตในละชองตองเปนคําที่ไมซํ้ากัน ควรเปนภาษาอังกฤษและไมมีการเวนวรรค

ระหวางคํา 

5. ทุกๆบรรทัดของตารางตองมีจํานวนชองเก็บขอมูลเทากันเสมอ 

6. ไมควรมีชองวางในแตละรายการ ถาไมมีขอมูล ควรบันทึกสัญลักษณหรือคําบรรยายใหทราบวาไมมีขอมูล 

 

ลักษณะขอมูลที่จัดเก็บอยางไมเหมาะสม 
 ขอมูลที่จัดเก็บอยางไมเหมาะสมมีหลายแบบ ที่พบบอยๆ ไดแก 

ก. เก็บขอมูลรวมไวในชองเดียวกัน ทั้งที่ควรแยกเก็บไวแตละชอง เชน เก็บวันที่เริ่มงานและวันที่ส้ินสุดงานไวใน

ชองเดียวกัน หรือ เก็บ คํานําหนา ชื่อ นามสกุลไวในชองเดียวกัน 

ข. เก็บขอมูลในรูปแบบที่ไมถูกตองหรือไมเหมาะสมกับลักษณะของขอมูล เชน เก็บวันที่ เดือน ป ไวในรูปแบบ

ขอความ หรือใชป พ.ศ. แทน ป ค.ศ. เก็บจํานวนตัวเลขในรูปแบบขอความ 

ค. แยกเก็บขอมูลไวหลายตาราง ทั้งที่สามารถเก็บไวในตารางเดียวกันได 
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การแกไขขอมูลที่จัดเก็บอยางไมเหมาะสม 
 การแกไขขอมูลที่จัดเก็บอยางไมเหมาะสม ควรใชโปรแกรมจัดการขอมูลชวย เชน โปรแกรม excel [3] 

สามารถชวยแกไขชอมูลได เพราะสามารถบันทึกสูตร หรือ ฟงกชั่นเพื่อชวยแกไขขอมูลได ดังกรณีตางๆเหลาน้ี 

 

ตัวอยางการแกไข กรณี เก็บขอมูลรวมไวในชองเดียวกันท้ังท่ีควรแยกเก็บไวแตละชอง 

 ขอมูลลักษณะน้ี มักมีขอมูลหลายประเภทอยูในชองเดียวกัน ดังตัวอยางในภาพที่ 2.1 

 

การเก็บขอมูลไวชองเดียวกัน 

(ลักษณะท่ีผิดพลาด) 

การแยกเก็บขอมูลไวแตละชอง 

(ลักษณะท่ีถูกตอง) 

ชื่อ-นามสกุล คํานําหนา ชื่อ นามสกุล 

นายเดนดวง รักษาความสุข นาย เดนดวง รักษาความสุข 

นางสาวสุขตา สุขใจ นางสาว สุขตา สุขใจ 

นางสะอาด เย็นชื่น นาง สะอาด เย็นชื่น 

 

ภาพท่ี 2.1 การเก็บขอมูลคํานําหนา ช่ือ นามสกุล ไวในชองเดียวกัน 

 

แบบฝกหัด 2.1 การใช Excel แกไขขอมูล คํานําหนา ช่ือ นามสกุล ท่ีเก็บไวในชองเดียวกัน ใหไปอยูแตละชอง 

 

 เปดไฟลแบบฝกหัด Ex2.1 จะไดขอมูลตัวอยางดังน้ี 

 
 

 เพิ่มคอลัมภเพื่อปฏิบัติการระบุแยกคํานําหนาเปน 3 ประเภทในชอง B1, C1, D1 ดังน้ี 
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ใสสูตรในชอง B2, C2, D2 แลว copy สูตร ลงไปในบรรทัดที่ 3-4 ดังน้ี 

ชอง สูตร คัดลอกไปยัง 

B2 =FIND("นางสาว",A2) B3:B4 

C2 =FIND("นาย",A2) C3:C4 

D2 =FIND("นาง",A2) D3:D4 

 

 

 เม่ือดําเนินการเสร็จแลวจะไดผลลัพธดังน้ี 

 
 

 สูตรใน คอลัมภ B ใชคนหาวาในคอลัมภ A ของแตละรายการมีคําวา “นางสาว” อยูหรือไม ถามีคําวา 

“นางสาว” อยูจะไดผลลัพธการคนหาเปนเลข 1 แตถาไมมี โปรแกรม Excel จะแสดงความผิดพลาด เปนขอความ 

#VALUE! แสดงวาไมสามารถคนหาคําทีกําหนดได ผลลัพธในคอลัมภ C และ D จึงไดผลในทํานองเดียวกัน 

  

ตอไปใหเพิ่มคอลัมภเพื่อปฏิบัติการสรุปคํานําหนาเปน 3 ประเภทในชอง E1, F1, G1 ดังน้ี 

 
 

 Copy ขอมูลจากชวง B2 ถึง D4 แลวเลือกคําส่ัง Paste Special ในชอง E1 ดังน้ี 
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 เลือกวางเฉพาะขอมูล (Values) จากกรอบ Paste Special ดังน้ี 

 

 
 

 

 ขอมูลจากชวง B2 ถึง D4 จะมาอยูในชวง E2 ถึง G4 ดังน้ี 
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เลือกชวงขอมูลในคอลัมภ E, F, G แลวเลือกคําส่ัง Replace ใหแทนคา #VALUE! ดวยชองวาง ดังน้ี 

 
 

  

 

เม่ือ Replace เสร็จแลว จะไดผลลัพธดังน้ี 

 
 

 เพิ่มคอลัมภ H อีกคอลัมภหน่ึง เพื่อแยกคํานําหนา ออกมา ดังน้ี 

 
 

 พิมพสูตรในชอง H2 แลว copy สูตรลงไปในชอง H3, H4  ดังน้ี 

ชอง สูตร คัดลอกไปยัง 

H2 =IF(G2,(IF(E2,"นางสาว","นาง")),"นาย") H3:H4 

 

 สูตรดังกลาวขางตน จะตรวจสอบขอมูลวาคํานําหนามีคําวา “นาง” อยูหรือไม ถาไมใช จะเปนนาย แตถามีคํา

วา นาง ก็จะตรวจสอบอีกครั้งวาเปนนางสาวหรือไม ผลลัพธที่ไดเปนดังน้ี  
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 สุดทายเพิ่มคอลัมภชื่อและนามสกุลในคอลัมภ I ชือ่ในคอลัมภ J และนามสกุลในคอลัมภ K แลวใสสูตรดังน้ี 

ชอง สูตร คัดลอกไปยัง 

I2 =SUBSTITUTE(A2,H2,"") I3:I4 
J2 =LEFT(I2,FIND(" ",I2)) J3:J4 
K2 =RIGHT(I2,LEN(I2)-FIND(" ",I2)) K3:K4 
 

 

 

 

 

 ผลลัพธที่ไดเปนดังภาพตอไปน้ี 

 
 

 สุดทาย เราจะไดคอลัมภคํานําหนา ชื่อ นามสกุล แยกออกมาเปนคนละคอลัมภ สามารถนําเขาคลังขอมูลได

ตอไป 

 

การแกไข กรณี เก็บขอมูลในรูปแบบท่ีไมถูกตองหรือไมเหมาะสมกับลักษณะของขอมูล 

 ขอมูลลักษณะน้ี มักจัดเก็บในรูปแบบที่ไมถูกตองหรือไมเหมาะสมกับลักษณะของขอมูล ดังตัวอยางในภาพที่ 

2.2 

 

รูปแบบท่ีผิดพลาด ประเภทขอมูล รูปแบบท่ีถูกตอง 

15 มีนาคม 2556, 15/3/2556, 15-3-2556 วันที่ 15 มีนาคม 2013, 15/3/2013, 15-มี.ค.-

2013 

9.30 น. , 15.29.08 เวลา 9:30 น. , 15:29:08 

 

ภาพท่ี 2.2 การเก็บขอมูลในรูปแบบท่ีไมถูกตองหรือไมเหมาะสมกับลักษณะของขอมูล 
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บทที่ 3  
การนําเขาขอมูลและการจัดโครงสรางพื้นฐานคลังขอมูล 

 
เม่ือจัดเตรียมและตรวจสอบขอมูลใหอยูในลักษณะที่เหมาะสมแลว ขั้นตอนตอไปคือการนําขอมูลเขาสู

คลังขอมูล ในที่น้ีจะใชโปรแกรมที่สรางคลังขอมูลและนําเขาขอมูลชื่อ Qlikview 

 โปรแกรม Qlikview เปนโปรแกรมที่บริษัท Qliktech International พัฒนาขึ้น เพื่อใชวิเคราะห

ขอมูลและนําเสนอขอมูล ซ่ึงมีหลาย version เราสามารถ download version ที่ใหทดลองใชงานไดที่ 

http://www.qlikview.com/us/explore/experience/free-download [4] ซ่ึงจะเปน version ที่

ใหใชงานไดฟรี โดยมีขอจํากัดคือไมสามารถนําขอมูลไปใชทีเครื่องอ่ืนได 

 เราจะทดลองใชโปรแกรม Qlikview พิจารณาลักษณะขอมูลตัวผูปวย โดยเริ่มจากการนําขอมูลผูปวยเขาสู

โปรแกรม ตามขั้นตอนดังน้ี 

 
ขั้นที่ 1 เลือกเมนูและคําส่ังตามลําดับดังน้ี (กรณีน้ีจัดเตรียมขอมูลโดยใช excel) 

 File  New 
 จะปรากฎ Dialog box ดังตอไปน้ี 
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ขั้นที่ 2 กดปุม Browse เพื่อ ไปยังตํ าแหนงที่ เ ก็บขอ มูล ในตัวอยาง น้ี น้ีจะใชขอมูลจากไฟล 

admission.xlsx  เลือก File ชื่อ admission แลวกดปุม Open 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
เม่ือเลือกแลวชือ่ไฟลจะเขามาอยูในชอง File Path: เสร็จแลวกดปุม Next step ดานลางขวา 
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เม่ือกดปุม Next step จะปรากฏ หนาตาง Step 2 ใหกดปุมเลือก Use column heads from 

data file บริเวณกลางหนาจอ ดังภาพดานลาง 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

ขั้นที่ 3 กดปุม Next step จะมี Dialog box ขึ้นใหตั้งชื่อ File ของ Qlikview ในที่น้ีตั้งชื่อเปน 

HDC เสร็จแลวกดปุม Save 
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 กดปุม Next ไปขั้นตอนที่ 4 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ขั้นที่ 4 Qlickview จะใหเลือกวาจะสราง Chart แบบใด ใหเลือก Bar chart แลวกดปุม Next 

step 
ขั้นที่ 5 Qlickview จะใหตัวแปรที่จะแสดงผลใน แกนนอน (Dimension) หรือ แกน X ของกราฟ ให

เลือกตัวแปรที่ตองการสรางเปนกราฟแทงตางๆบนแกน X ในที่น้ีเลือกตัวแปร WARDADMIT เพื่อสรางกราฟแสดง

แผนกที่รับผูปวย สําหรับแกน Y หรือ Expression เลือก Count the number of และ AN เพื่อใหนับ

จํานวนผูปวย แลวกดปุม Next step 
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ขั้นที่ 6 Qlickview จะถามถึง object ที่ตองการสรางเพิ่ม ใหกดปุมเลือก Listboxes แลวเลือกฟลด 

WARDADMIT ในชอง Choose fields แลวกดปุม Create 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
\ 
 
 
 
 โปรแกรม Qlikview จะสราง Object พื้นฐานมาใหดังภาพดานลาง 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
กลุม Object พื้นฐานประกอบดวย กราฟแทงแสดงผลการนับจํานวนผูปวยจําแนกตามรหัสแผนกที่รับไว

รักษาเรียงตามจํานวนผูปวยจากมากไปนอย นอกจากน้ัน ยังสราง List Box ที่มีชื่อวา WARDADMIT, สราง 

Current Selections Box ที่ใชแสดงสถานการณเลือกปจจุบัน และ Search Box อยูเปนกลุมดานซายบน

ของหนาจอแสดงผล  

ใหกดปุม Save เพื่อบันทึกผลงานขั้นตน 
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 เราสามารถปรับเปล่ียนลักษณะของกราฟแทงน้ีไดหลายแบบ โดยการคลิกขวาที่รูปกราฟจะมีเมนูขึ้นมาดังน้ี 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 เลือกรายการแรกในเมนู คือ Properties เพื่อปรับเปล่ียนรูปแบบของ กราฟ 

 
 
 

 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 จะปรากฏ Dialog box ชื่อ Chart properties ขึ้นมา ใน Tab General ใหตั้งชื่อในชอง 

Window Title ดานบนซายสุดวา “จํานวนผูปวยจําแนกตามแผนกที่รับไวรักษา” แลวกดปุม Apply ดานลาง 
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 ตอไปใหกดเลือก Tab ชื่อ Expressions แลวกดเลือก Values on Data Points ดานลาง ดัง

ภาพ 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 เสร็จแลวกดปุม Apply และ OK จะพบวากราฟมีรายละเอียดเพิ่มเติมดังภาพตอไป 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

กดเลอืก Values on Data 

Points เพือแสดงค่าที

นบัได้ 
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 กราฟจะแสดงจํานวนยอดผูปวยที่นับไดในแตละเพศ โดยในขณะน้ีกราฟแทงจะเรียงตามจํานวนที่มากไลลงไป

จํานวนที่นอย หากตองการใหแสดงกราฟแทงตามรหัสเพศ โดยใหแสดงผลเพศชาย (SEX =1) มากอนสามารถปรับ

โดยคลิกขวาเรียก Dialog box Chart Properties แลวเลือก Tab Sort ขึ้นมาแกไขดังน้ี 

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 ยกเลิกการเลือก Y-value แลวเลือก เลือก Sort by .. Text ซ่ึงจะเปนการเรียงตามลําดับอักษร แลวกด

ปุม OK จะไดผลลัพธคือ 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 ตอไป สราง Object ใหม เรียกวา Table Box โดยเลือก เมนู Object => New Sheet Object 

=> Table Box  ดังน้ี 



20 
 

 
 จะปรากฏ Dialog box  ชื่อ New Table Box ดังน้ี 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 ในชอง Title พิมพชื่อตารางเปน “รายการผูปวย” กดปุม Add All ตรงกลาง แลว จะไดผลดังน้ี 
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 กดปุม Load Order ทางดานขวาของกรอบโตตอบ แลวกดปุม OK จะไดตารางแสดงรายการผูปวยดังน้ี 
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ตารางน้ีจะเชื่อมโยงความสัมพันธกับ กราฟแทง และ List box รายการเพศโดยอัตโนมัติ ถาเราคลิกเลือกที่

รายการใดๆ หนาตางทั้งหมดจะแสดงขอมูลที่สัมพันธกับรายการที่เราเลือก เชน ถาคลิกที่กราฟแทงแผนกที่เปนรหัส 

100 จะไดรายการของผูปวยทกุรายที่รับเขาไวรักษาในแผนกน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ลักษณะขอมูลในรูปแบบฐานขอมูลที่เหมาะสม 

 ขอมูลที่จัดเก็บในรูปแบบฐานขอมูลที่ดี จะตองมีลักษณะดังตอไปน้ี 

 
 
 
 
 
 

การจัดโครงสรางพ้ืนฐานของคลังขอมลู 

 โครงสรางพื้นฐานของคลังขอมูล จะประกอบไปดวยสวนตางๆทีสํ่าคัญดังตอไปน้ี 

1. ขอมูลที่นําเขาไปอยูในคลังขอมูล โดยอยางนอยจะตองมีขอมูล 1 ตาราง 

2. ตารางแสดงขอมูลบางสวนหรือขอมูลทั้งหมดที่อยูในคลังขอมูล 

3. กราฟแสดงลักษณะของขอมูลในรูปแบบตางๆ 

4. กลองแสดงตัวแปรและคาของตัวแปรทั้งหมด (List Box or Multi Box) 

5. กลองแสดงสถานะการเลือกดูขอมูล (Current Selection Box) 

6. เครื่องมือชวยอ่ืนๆ เชน กลองคนหา (Search Box) 

 
การดําเนินการในสวนที่ผานมา ในใชโปรแกรม Qlikview สรางคลังขอมูลโดยไดสวนที่สําคัญ รายการที่ 1-6 

แลว  
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 กลองแสดงสถานะ Current Selections เปนเครื่องมือที่ใชตรวจสอบรายการที่เลือกอยูในปจจุบัน การ

สรางหนาตางแสดงสถานะ Current Selection ทําไดโดยเลือก เมนู Object => New Sheet Object => 

Current Selection Box.. ดังน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 เม่ือเลือก Current Selections Box.. จะได Dialog Box ดังน้ี 
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 กดปุม OK จะไดหนาตางใหมชื่อ Current Selections ใหจัดตําแหนงใหเหมาะสม 

 
 
 
 
 
 
 
 
 
 
 
 
 
อยางไรก็ตาม เรามี Current Selections box เดิมอยูแลว สามารถลบทิ้งไปได หน่ึงอัน โดย คลิกขวาที่ 

Current Selections box อันใดอันหน่ึงแลวเลือก รายการ Remove ดังภาพดานลาง 

 

 
 
 หนาตาง Current Selections น้ีจะแสดงการเลือกขอมูลที่ผูใชกําลังเลือกดูอยู เชน ในภาพดานบนน้ี ผูใช

กําลังเลือกขอมูลเฉพาะผูปวยเพศหญิง ในชองจึงแสดงวามีการเลือกขอมูลผูปวยเพศหญิง หากตองการยกเลิกการเลือกให

กดปุมรูปยางลบ ในหนาตาง Current Selections หรือกดปุม Clear ใน Tool bar ดานบนของโปรแกรม 

Qlikview 
 

 
 
 
ปุม Clear ใชยกเลิก การเลือกทั้งหมด สวนปุม Back ใชยกเลิกการเลือกครั้งลาสุด 1 ครั้ง หรือ ถอย

กลับไปสถานะกอนหนา เหมือนปุมยอนกลับใน Web Browser 
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การสรางกลองคนหาทําไดโดย เลือก เมนู Object => New Sheet Object => Search Object.. 

ดังน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
จะปรากฏกลองโตตอบดังน้ี 
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ใหกําหนดวา กลองคนหาจะใชคนหาใน Fields ใดบาง ถาตองการใหคนหาไดทุก Fields ใหเลือก All 

Fields แลวกดปุม OK จะไดกลองคนหาดังน้ี 

 
 
 
 
ลองพิมพขอความใดๆเขาไปในกลองคนหา กลองคนหาจะแสดงรายการขอมูลที่มีขอความลักษณะน้ันอยูดังน้ี 
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บทที่ 4  
การวิเคราะหขอมูลในคลังขอมูล 

 
การวิเคราะหขอมูลคือการเปล่ียนขอมูลดิบใหกลายเปนสารสนเทศ หมายถึงการทําใหขอมูลมีความหมายมาก

ขึ้น ทําใหเห็นภาพดานตางๆของขอมูล เพื่อใหสามารถนําสารสนเทศไปใชประโยชนในดานตางๆไดมากขึ้น การวิเคราะห

ขอมูลในคลังขอมูลที่สรางจากโปรแกรม Qlikview น้ี จะมีขั้นตอนที่สําคัญดังน้ี 

1. การทําใหขอมูลมองเห็นได (Data Visualization) 

2. การใชการคํานวณเพื่อวิเคราะหความหมายดานตางๆของขอมูล 

3. การนําเสนอขอมูลที่วิเคราะหแลวในรูปแบบสารสนเทศเพื่อนําไปใชประโยชน 

 

การทําใหขอมูลมองเห็นได  
 การทําใหขอมูลมองเห็นได คือ การนําเสนอขอมูลในรูปแบบกราฟ หรือทําใหเปนภาพ แผนภูมิ แผนผัง มีการ

จัดรูปแบบใหเปนระเบียบเรียบรอย และเขาใจงาย ซ่ึงการทําใหขอมูลมองเห็นจะมีประโยชนอยางยิ่งในการส่ือสาร เพราะ

ทําใหผูรับขอมูลเขาใจความหมายของขอมูลไดโดยงาย ปจจุบัน มีองคกรหลายแหงในระดับนานาชาติ เชน บริษัทผลิต

รถยนตโตโยตา ใชการทําขอมูลมองเห็นได เปนเครื่องมือสําหรับการบริหารจัดการและการปฏิรูปงานตางๆ 

เราสามารถใชโปรแกรม Qlikview ทําขอมูลใหมองเห็นไดโดยงาย ในลักษณะตางๆดังตอไปน้ี 

 
การสรางกราฟแทง 

 กอนเริ่มสรางกราฟ ควรปรับแตง toolbar ของโปรแกรม Qlikview เพื่อเพิ่มแถบเครื่องมือในการสราง

วัตถุตางๆ โดยเลือกเมนู View => Toolbars => Design ดังน้ี 
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คําส่ังจะเปดแถบเครื่องมือขึ้นมา เพิ่มขึ้นอีก 1 แถบดังภาพดานลาง 

เราสามารถใชแถบเครื่องมือที่เพิ่มขึ้นมาน้ี เพิ่มวัตถุตางๆและจัดรูปแบบคลังขอมูลเขาเราไดโดยสะดวกงายดาย 

เริ่มจากการเพิ่มกราฟโดยกดปุม  แลวใสชื่อในชอง Window Title เปน “จํานวนผูปวยจําแนกตามโรงพยาบาลที่

รักษา” ดังน้ี 

เลือก Chart Type เปนกราฟแทง (รูปแรกสุด) แลวกดปุม Next จะไดกรอบโตตอบ Dimensions 

ขึ้นมา ใหเลือก HOSPCODE จากชอง Available Fields/Groups ที่อยูดานซายบนสุดแลวกดปุม Add ดัง

ภาพตอไปนี้ 
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กดปุม Next ไปสูขั้นตอนตอไป 

ในกรอบโตตอบ Edit Expression เลือกคําส่ัง Total count จาก combo box ชื่อ 

Aggregation และเลือก AN ใน combo box ชื่อ Field แลว check เครื่องหมายถูกใน check box ชื่อ 

Distinct กดปุม Paste จะไดภาพดานลาง 

เลือก Aggreation เปน Total count เลือก AN ในชอง Field แลวคลิกเลือก Distinct ในชอง check 

box ดังภาพดานลาง 

 
กดปุม OK ไปสูขั้นตอนตอไป ในกรอบโตตอบ Expressions เลือก check box ชื่อ Values on 

Data Points จะไดภาพดานลาง 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. Select Total Count 

2. Select AN 

3. Select Distinct 
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กดปุม Finish แลวจะไดกราฟแทงดังภาพดานลางน้ี 

 
 
 
 

 
 
 
 
 
 
 
 
 
 

 
การสรางกราฟวงกลม 

กดปุม  แลวใสชื่อในชอง Window Title เปน “จํานวนผูปวยจําแนกตาม Discharge Status” 

แลวกดปุมเลือกประเภทของกราฟเปนกราฟวงกลม           ดังน้ี 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
กดปุม Next จะไดกรอบโตตอบ Dimensions ขึ้นมา ใหเลือก DISCHSTATUS จากชอง 

Available Fields/Groups ที่อยูดานซายบนสุดแลวกดปุม Add ดังภาพตอไปน้ี 
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กดปุม Next ไปสูขั้นตอนตอไป 

 
 
เลือก Aggreation เปน Total count เลือก AN ในชอง Field แลวคลิกเลือก Distinct ในชอง check 

box ดังภาพดานลาง 

 
 
กดปุม OK ไปสูขั้นตอนตอไป ในกรอบโตตอบ Expressions เลือก check box ชื่อ Values on 

Data Points จะไดภาพตอไป 

 
 
 
 

1. Select Total Count 

2. Select AN 

3. Select Distinct 



32 
 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
กดปุม Finish แลวจะไดกราฟวงกลมดังภาพดานลางน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
เราสามารถใชหลักการเดียวกันน้ี ในการสรางกราฟรูปแบบอ่ืน เชน กราฟรูปกรวย (Funnel Chart) กราฟ

เสน (Line Chart) หรือกราฟอ่ืนๆ 

 
ฝกฝนเพิ่มเติม 

ลองสรางกราฟรูปกรวย แสดงจํานวนผูปวยจําแนกตามสิทธิการรักษา 
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บทที่ 5  
การเช่ือมโยงตารางขอมูลหลายตารางเขาหากัน 

 
คลังขอมูลจะเปนแหลงรวบรวมขอมูลของหนวยงานเพื่อใชบริการขอมูล ดังน้ันในคลังขอมูลจะมีขอมูลอยู

มากมาย ขอมูลมักจะเก็บอยูในตารางหลายตาราง เราจะตองเชื่อมโยงตารางเหลาน้ีเขาหากัน เพื่อใหการคนหาและ

วิเคราะหขอมูลเปนไปอยางมีประสิทธิภาพ 

ในบทน้ีจะเปนการฝกเชื่อมโยงขอมูลผูปวยเขากับขอมูลอ่ืนๆ เชน ขอมูลลักษณะทั่วไปของผูปวย หรือ ขอมูล

รหัสกลุมโรค ICD ของผูปวย เปนตน 
 
การเช่ือมโยงขอมูลผูปวยเขากับขอมูลการรับผูปวยเขารักษาในโรงพยาบาล 

ในบทน้ื เราจะใชชุดขอมูลจาก 43 แฟมมาตรฐานที่กําหนดโดยสํานักนโยบายและยุทธศาสตร กระทรวง

สาธารณสุข มาเชื่อมโยงกันในคลังขอมูล โดยจะเริ่มจากการนําเขาและเชื่อมโยงแฟม  Admission กับแฟม Person 

เราไดนําเขาแฟม Admission เขามาแลว โดยแฟม Admission มีโครงสรางขอมูลดังน้ี 

 

NAME 

(3) 

DESCRIPTION 

(4) 
PK(5) TYPE(6) WIDTH(7) 

HOSPCODE  รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y  C 5 

PID   ทะเบียนของบคุคลทีมาขึนทะเบียนในสถานบริการนนัๆ ใช้สําหรับ

เชือมโยงหาตวับคุคลในแฟ้มอืน ๆ (สามารถกําหนดได้

ตงัแต่ 1-15 หลกั) 

Y  C 15 

SEQ   ลําดบัทีของการบริการทีกําหนดโดยโปรแกรมเรียงลําดบัโดยไม่ซํา

กนั สําหรับการมารับบริการแต่ละครัง (visit) 

  C 16 

AN เลขทีผู้ป่วยใน (AN) Y  C 9 

DATETIME_ADMIT วนัเดือนปีและเวลาทีรับผู้ ป่วยไว้ในโรงพยาบาล กําหนดเป็น ค.ศ.

(YYYYMMDDHHMMSS) 

  DT 14 

WARDADMIT รหสัแผนกทีรับผู้ ป่วย อ้างอิงตามมาตรฐาน สนย.   C 5 

INSTYPE รหสัสทิธิมาตรฐาน ทีใช้ในการมารับบริการ (สทิธิหลกัในการ 

admit ครังนนั) 

  C 4 

TYPEIN 1 = มารับบริการเอง, 2 = มารับบริการตามนดัหมาย, 3 = ได้รับ

การสง่ต่อจากสถานพยาบาลอืน, 4 = ได้รับการสง่ตวั

จากบริการ EMS 

  C 1 

CAUSEIN 1 = เพือการวนิจิฉยัและรักษา, 2 = เพือการวนิจิฉยั, 3 = เพือการ

รักษาต่อเนือง, 4 = เพือการดูแลต่อใกล้บ้าน, 5 = ตาม

ความต้องการผู้ป่วย 

  C 1 
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NAME 

(3) 

DESCRIPTION 

(4) 

PK(5) TYPE(6) WIDTH(7) 

ADMITWEIGHT นําหนกัผู้ป่วยแรกรับ (กิโลกรัม) จุดทศนยิม 1 ตําแหนง่   N 5 

ADMITHEIGHT สว่นสงูผู้ป่วยแรกรับ (ซ.ม.)   N 3 

DATETIME_DISCH วนัเดือนปีและเวลาทีจําหนา่ยผู้ป่วย กําหนดเป็น ค.ศ.

(YYYYMMDDHHMMSS) 

  DT 14 

WARDDISCH รหสัแผนกทีจําหนา่ยผู้ป่วย อ้างอิงตามมาตรฐาน สนย.   C 5 

DISCHSTATUS รหสัสถานภาพการจําหนา่ยผู้ป่วย   C 1 

DISCHTYPE รหสัชนดิการจําหนา่ยผู้ ป่วย   C 1 

REFEROUTHOSP รหสัสถานพยาบาลทีสง่ผู้ป่วยไปรักษาต่อ   C 5 

CAUSEOUT 1 = เพือการวนิจิฉยัและรักษา, 2 = เพือการวนิจิฉยั, 3 = เพือการ

รักษาต่อเนือง, 4 = เพือการดูแลต่อใกล้บ้าน, 5 = ตาม

ความต้องการผู้ป่วย 

  C 1 

COST ราคาทนุซงึรวมค่ายาและเวชภัณฑ์ทงัหมดรวมทงัค่าบริการ

ทางการแพทย์ (รวมจุดทศนยิมและเลขหลงัจุด 2 

ตําแหนง่) 

  N 11 

PRICE ราคาขายซงึรวมค่ายาและเวชภณัฑ์ ทงัหมดรวมทงัค่าบริการ

ทางการแพทย์ (รวมจุดทศนยิมและเลขหลงัจุด 2 

ตําแหนง่) 

  N 11 

PAYPRICE จํานวนเงินทีเรียกเก็บ เนืองจากเป็นคา่ใช้จ่ายทีเบกิไม่ได้ (รวมจุด

ทศนยิมและเลขหลงัจุด 2 ตําแหนง่) โดยถ้าไม่มีการเรียก

เก็บให้ใสเ่ลขศูนย์ 

  N 11 

ACTUALPAY จํานวนเงินทีจ่ายจริง ถ้าไม่มีการจ่ายให้ใสเ่ลขศูนย์   N 11 

PROVIDER เลขทีผู้ให้บริการ ออกโดยโปรแกรม ไม่ซํากนัในสถานพยาบาล

เดียวกนั (หมอผู้รบัผดิชอบคนไข้หลกั) 

  C 15 

D_UPDATE วนัทีเพมิและปรับปรุงข้อมูล  กําหนดรูปแบบเป็น ปีเดือนวนัชัวโมง

นาทีวนิาที (YYYYMMDDHHMMSS) และเป็นปีคริสต

ศกัราช 

  DT 14 
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แฟม Person เปนแฟมที่เก็บรายละเอียดขอมูลผูปวยแตละราย มีโครงสรางขอมูลดังน้ี 

NAME 

(3) 

DESCRIPTION 

(4) 
PK(5) 

TYPE 

(6) 

WIDTH 

(7) 

HOSPCODE รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y  C 5 

CID เลขประจําตวัประชาชน ตามกรมการปกครองกําหนดเป็นรหสัประจําตัว

บคุคล 

  C 13 

PID ทะเบียนของบคุคลทีมาขึนทะเบียนในสถานบริการนนัๆ ใช้สําหรับ

เชือมโยงหาตวับคุคลในแฟ้มอืน ๆ (สามารถกําหนดได้ตงัแต่ 1-

15 หลกั)(program generate) 

Y C 15 

HID รหสับ้านทีกําหนดโดยโปรแกรมจากแฟ้ม HOME และรหสันีจะซํากนัได้

หากบคุคลอาศยัอยู่ในหลงัคาเรือนเดียวกนั อ้างอิงเพือค้นหา

บ้านในแฟ้ม HOME (หลงัคาเรือนในเขตรับผดิชอบ) กรณีที

อาศยัในเขตรบัผดิชอบ 

  C 14 

PRENAME คํานําหน้าชือ อ้างอิงมาตรฐานตามกรมการปกครอง   C 3 

NAME ชือ   C 50 

LNAME นามสกุล   C 50 

HN 
เลขทะเบียนการมารับบริการ(สามารถกําหนดได้ตงัแต่ 1-15 หลกั) ใน

กรณีทีมีเลขทะเบียนทีต่างไปจาก PID 

  C 15 

SEX 1 = ชาย , 2 = หญิง   C 1 

BIRTH วนัเดือนปีเกิด กําหนดเป็น ค.ศ. (YYYYMMDD) (หากไม่ทราบวนั เดือน

ทีเกิด แต่ทราบ ค.ศ เกิด ให้กําหนดวนัเกิดเป็นวนัที 1 มกราคม

ของปี ค.ศ.นนัๆ) 

  C 8 

MSTATUS 1 = โสด, 2 = คู,่ 3 = ม่าย, 4 = หย่า, 5 = แยก, 6 = สมณะ,  9=ไม่ทราบ   C 1 

OCCUPATION_OLD รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์   C 3 

OCCUPATION_NEW รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์   C 4 

RACE รหสัมาตรฐานตามกรมการปกครอง   C 3 

NATION รหสัมาตรฐานตามกรมการปกครอง ถ้าไม่ทราบให้ระบ ุ999 ตาม

รหสัมาตรฐาน 

  C 3 

RELIGION รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์   C 2 

EDUCATION รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์   C 2 

FSTATUS 1 = เจ้าบ้าน  , 2 = ผู้อาศยั   C 1 
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NAME 

(3) 

DESCRIPTION 

(4) 
PK(5) 

TYPE 

(6) 

WIDTH 

(7) 

FATHER รหสับตัรประชาชนของบดิา   C 13 

MOTHER รหสับตัรประชาชนของมารดา   C 13 

COUPLE รหสับตัรประชาชนของคูส่มรส   C 13 

VSTATUS 1 = กํานนั ผู้ใหญ่บ้าน, 2 = อสม., 3 = แพทย์ประจําตําบล,  

4 = สมาชิกอบต., 5 = อืนๆ 

  C 1 

MOVEIN วนัเดือนปีทีย้ายเข้า ในเขตรับผดิชอบ กําหนดเป็น ค.ศ.(YYYYMMDD)   C 8 

DISCHARGE 1 = ตาย , 2 = ย้าย  , 3 = สาบสญู ,9 =ไม่จําหนา่ย   C 1 

DDISCHARGE วนัเดือนปีทีจําหนา่ย กําหนดเป็น ค.ศ. (YYYYMMDD)   C 8 

ABOGROUP 1 = A , 2 = B , 3 = AB , 4 = O   C 1 

RHGROUP 1 = positive , 2 = negative   C 1 

LABOR รหสัมาตรฐานสํานกันโยบายและยุทธศาสตร์      C 2 

PASSPORT เลขที passport   C 8 

TYPEAREA 1=มีชืออยู่ตามทะเบียนบ้านในเขตรับผดิชอบและอยู่จริง2= มีชืออตาม

ทะเบีบนบ้านในเขตรับผดิชอบแต่ตวัไม่อยู่จริง3= มาอาศยัอยู่ในเขต

รับผดิชอบ(ตามทะเบียนบ้านในเขตรับผดิชอบ)แต่ทะเบียนบ้านอยู่นอก

เขตรับผดิชอบ4= ทีอาศยัอยู่นอกเขตรับผดิชอบและทะเบียนบ้านไม่อยู่

ในเขตรับผดิชอบ เข้ามารับบริการหรือเคยอยู่ในเขตรับผดิชอบ5=มา

อาศยัในเขตรับผดิชอบแต่ไม่ได้อยู่ตามทะเบียนบ้านในเขตรับผดิชอบ 

เช่น คนเร่ร่อน ไม่มีทีพกัอาศยั เป็นต้น   

  C 1 

D_UPDATE วนัทีเพมิและปรับปรุงข้อมูล  กําหนดรูปแบบเป็น ปีเดือนวนัชัวโมงนาที

วนิาที (YYYYMMDDHHMMSS) และเป็นปีคริสตศกัราช 

  C 14 

 
 

กอนนําแฟม Person เขาสูคลังขอมูล ตองจัดเตรียมแฟมในรูปแบบที่เหมาะสม โดยทําเปน text file 

นามสกุล .txt หรือ.csv หรือ .xml ใหเรียบรอย 
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 การนําแฟม Person เขาสูคลังขอมูลจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอนดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “Person”, ดังภาพ

หนาจอดานลาง 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
3. ใน tab Person พิมพขอความ “Person:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ

ขี้นบรรทัดใหมดังภาพหนาจอดานลาง 

 
 
 
 
 
 
 
 
 
 
 
4. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ Person ที่เก็บไวใน Folder ใดๆ เชนในที่น้ีอยูใน 

Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียดของไฟลดังภาพ

ดานลาง 
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4. เลือก Delimiter เปน | และเลือก Character Set เปน ภาษาไทย ดังภาพดานลาง 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. กดปุม Finish ดานลาง Qlikview จะสรางคําส่ังเพื่อใชในการนําเขาไฟลดังแสดงในภาพตอไป 
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6. กดปุม OK เพื่อปดหนาตาง Edit Script  
7. Save เพื่อบันทึกงานที่ทํามาแลว  
8. Reload ขอมูลทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน 

toolbar  
9. ตรวจสอบวามีตารางเขามาอยูในฐานขอมูลอยางครบถวนหรือไม โดยเลือก menu File => Table 

Viewer… หรือกดปุมรูป              ที่ปรากฏบน toolbar  
 
11. ถาขอมูลนําเขามาไดถูกตอง หนาตาง Table Viewer จะแสดงภาพตารางทั้งหมดที่อยูในคลังขอมูล มี

สองตารางหรือ ตาราง Admission และ Person เชื่อมโยงกัน (แสดงเสนเชื่อมโยง) โดยเลข HN ดัง

ภาพดานลาง  
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12. ถาไมพบภาพดังกลาว แสดงวาเกิดความผิดพลาดในขั้นตอนที่ผานมา ตองดําเนินการใหม โดยการเปด

หนาจอ Edit Script แลวลบขอความทั้งหมดที่อยูใน tab Person แลวดําเนินการตามขั้นตอน 3 ถึง 

11 ใหมทั้งหมด 

13. การเชื่อมโยงตารางในขณะน้ี เปนการเชื่อมโยงโดยอัตโนมัติ ที่เกิดจาก Qlikview จะเลือก Field ที่มี

ชื่อเดียวกันในตารางทั้งสองมาเชื่อมโยงกัน ดังภาพแสดงการเชื่อมโยงระหวาง 3 ฟลด  คือ 

HOSPCODE,  PID และ D_UPDATE โดยเชื่อมโยงเปน Synthetic Key ชื่อ $Syn1 แตการ

เชื่อมโยงอัตโนมัติ น้ี ไม เหมาะสมเพราะถาดูตามความเปนจริงแลว การเชื่อมโยงควรใช เฉพาะ 

HOSPCODE และ PID มาเชื่อมโยงกัน โดยไมเชื่อมโยงฟลด D_UPDATE เพราะฟลดน้ีไมไดเก็บ

ขอมูลที่จะใชเชื่อมโยงตารางได เราจึงควรแกไข Script ในหนา Main และ Person โดยการเปด

หนาจอ Edit Script และแกไขขอความ ดังตอไปน้ี 

แกไข Main ตั้งแตบรรทัดที่มีขอความ LOAD ลงไป 2 บรรทัดดังน้ี 
LOAD HOSPCODE, 
     HOSPCODE&PID AS ID,  
     SEQ,  
     AN,  
     DATETIME_ADMIT,   

….. 
 
แกไข Person รวม 2 ที่ เริ่มจากบรรทัดที่มีขอความ LOAD ลงไป 2 บรรทัดดังน้ี 

Person: 
LOAD HOSPCODE AS PSHOSPCODE,   
     CID,  
     PID, 
     HOSPCODE&PID AS ID,  
     HID,  
     PRENAME,   

….. 
และในบรรทัดที่มีขอความ D_UPDATE  ดังน้ี 

PASSPORT,  
     TYPEAREA,  
     D_UPDATE AS PSD_UPDATE 
FROM 
……  

 
14. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชือมโยงตารางดงัภาพต่อไปน ี
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การเช่ือมโยงขอมูลผูปวยเขากับขอมูลรหัส ICD 
 
ในการวิเคราะหขอมูลผูปวย เรื่องแรกที่สําคัญคือการวิเคราะหกลุมโรคที่พบในผูปวยที่ใหรหัสไวโดยใช 

International Classification of ICD โดยเราจะนําเขาขอมูลที่เก่ียวของกับ การใหรหัส ICD ของผูปวยรวม 

3 แฟม คือ DIAGNOSIS_OPD, DIAGNOSIS_IPD, PROCEDURE_OPD 

 
แฟม DIAGNOSIS_OPD เก็บขอมูลในโครงสรางขอมูลดังน้ี 

 
NAME 

(3) 

DESCRIPTION 

(4) 

PK 

(5) 

TYPE 

(6) 

WIDTH 

(7) 

HOSPCODE  รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y C 5 

PID   ทะเบียนของบคุคลทีมาขึนทะเบียนในสถานบริการนนัๆ ใช้สําหรับ

เชือมโยงหาตวับคุคลในแฟ้มอืน ๆ (สามารถกําหนดได้ตงัแต่ 1-

15 หลกั) 

Y C 15 

SEQ   
ลําดบัทีของการบริการทีกําหนดโดยโปรแกรมเรียงลําดบัโดยไม่ซํากนั 

สําหรับการมารับบริการแต่ละครัง (visit) 

Y C 16 

DATE_SERV วนัเดือนปีทีมารับบริการ กําหนดเป็น ค.ศ.(YYYYMMDD)   D 8 
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NAME 

(3) 

DESCRIPTION 

(4) 

PK 

(5) 

TYPE 

(6) 

WIDTH 

(7) 

DIAGTYPE 1 = PRINCIPLE DX (การวินจิฉยัโรคหลกั)  

4 = OTHER (อืน ๆ)  

5 = EXTERNAL CAUSE(สาเหตุภายนอก)  

6 = Additional Code (รหสัเสริม)  

7 = Morphology Code (รหสัเกียวกบัเนืองอก) 

 C 1 

DIAGCODE   รหสัโรค ICD - 10 - TM Y C 6 

CLINIC รหสัแผนกทีรับบริการ อ้างอิงตามมาตรฐาน สนย.  C 5 

PROVIDER เลขทีผู้ให้บริการ ออกโดยโปรแกรม ไม่ซํากนัในสถานพยาบาลเดียวกัน  C 15 

D_UPDATE วนัทีเพมิและปรับปรุงข้อมูล  กําหนดรูปแบบเป็น ปีเดือนวนัชัวโมงนาที

วนิาที (YYYYMMDDHHMMSS) และเป็นปีคริสตศกัราช 

 DT 14 

 
 
การนําแฟม DIAGNOSIS_OPD เขาสูคลังขอมูลจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอน

ดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “ICDOPD”, ใน 

tab ICDOPD พิมพขอความ “ICDOPD:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ

ขี้นบรรทัดใหมดังภาพหนาจอดานลาง 

 

 
 
3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ DIAGNOSIS_OPD ที่เก็บไวใน Folder ใดๆ 

เชนในทีน้ี่อยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียด
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ของไฟล ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย (ในกรณีเปด text file) ดังภาพ

ตอไป 

 

 
 
4. แกไข Script ในหนา ICDOPD ใหเปนดังตอไปน้ี 

ICDOPD: 
LOAD HOSPCODE&PID AS ID,  
     HOSPCODE&PID&SEQ AS OPDID,  
     HOSPCODE AS OPDHOS,            
     DATE_SERV,  
     DIAGTYPE AS ICDOPDTYPE,  
     DIAGCODE AS ICDOPD,  
     CLINIC 
FROM 
… 

 
5. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชือมโยงตารางดงัภาพต่อไปน ี
 
 



44 
 

 
 
แฟม DIAGNOSIS_IPD เก็บขอมูลในโครงสรางขอมูลดังน้ี 

 
NAME 

(3) 

DESCRIPTION 

(4) 

PK 

(5) 

TYPE 

(6) 

WIDTH 

(7) 

HOSPCODE  รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y C 5 

PID   ทะเบียนของบคุคลทีมาขึนทะเบียนในสถานบริการนนัๆ ใช้สําหรับ

เชือมโยงหาตวับคุคลในแฟ้มอืน ๆ (สามารถกําหนดได้ตงัแต่ 1-

15 หลกั) 

Y  C 15 

AN เลขทีผู้ป่วยใน (AN) Y  C 9 

DATETIME_ADMIT วนัเดือนปีและเวลาทีรับผู้ ป่วยไว้ในโรงพยาบาล กําหนดเป็น ค.ศ.

(YYYYMMDDHHMMSS) 

  DT 14 

WARDDIAG รหสัแผนกทีรับผู้ ป่วย อ้างอิงตามมาตรฐาน สนย.   C 5 

DIAGTYPE 1 = PRINCIPLE DX (การวินจิฉยัโรคหลกั)  

2 = CO-MORBIDITY(การวนิจิฉยัโรคร่วม)  

3 = COMPLICATION(การวนิจิฉยัโรคแทรก)  

4 = OTHER (อืน ๆ)  

5 = EXTERNAL CAUSE(สาเหตุภายนอก)   

6 = Additional Code (รหสัเสริม)  

7 = Morphology Code (รหสัเกียวกบัเนืองอก) 

  C 1 

DIAGCODE   รหสัโรค ICD - 10 - TM Y  C 6 

PROVIDER เลขทีผู้ให้บริการ ออกโดยโปรแกรม ไม่ซํากนัในสถานพยาบาลเดียวกัน   C 15 
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การนําแฟม DIAGNOSIS_IPD เขาสูคลังขอมูลจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอน

ดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “ICDIPD”, ใน 

tab ICDIPD พิมพขอความ “ICDIPD:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ   

ขึ้นบรรทัดใหมดังภาพหนาจอดานลาง 

 

 
 
3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ DIAGNOSIS_IPD ที่เก็บไวใน Folder ใดๆ เชน

ในที่น้ีอยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียดของ

ไฟล ถาเปด text file ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย หรือถาเปด 

excel file ใหตรวจสอบขอมูลใหเรียบรอย ดังภาพตอไป 
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4. แกไข Script ในหนา ICDIPD ใหเปนดังตอไปน้ี 
ICDIPD: 
LOAD HOSPCODE&PID&AN AS ANID,  
     WARDDIAG,  
     DIAGTYPE AS ICDIPDTYPE,  
     DIAGCODE AS ICDIPD 
 
FROM 
… 

  
5. แกไข Script ในหนา Main ใหเปนดังตอไปน้ี 

LOAD HOSPCODE, 
HOSPCODE&PID AS ID,  
SEQ,  
HOSPCODE&PID&AN AS ANID, 
AN,   

 ……. 
 

6. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชือมโยงตารางดงัภาพต่อไปน ี
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แฟม PROCEDURE_OPD เก็บขอมูลในโครงสรางขอมูลดังน้ี 

NAME 

(3) 

DESCRIPTION 

(4) 

PK 

(5) 

TYPE 

(6) 

WIDTH 

(7) 

HOSPCODE รหสัสถานพยาบาล ตามมาตรฐานสํานกันโยบายและยุทธศาสตร์ Y C 5 

PID ทะเบียนของบคุคลทีมาขึนทะเบียนในสถานบริการนนัๆ ใช้สําหรับ

เชือมโยงหาตวับคุคลในแฟ้มอืน ๆ (สามารถกําหนดได้ตงัแต่ 1-

15 หลกั) 

Y C 15 

SEQ ลําดบัทีของการบริการทีกําหนดโดยโปรแกรมเรียงลําดบัโดยไม่ซํากนั 

สําหรับการมารับบริการแต่ละครัง (visit) 

Y C 16 

DATE_SERV วนัเดือนปีทีมารับบริการ กําหนดเป็น ค.ศ.(YYYYMMDD) D 8 

CLINIC รหสัแผนกทีรับบริการ อ้างอิงตามมาตรฐาน สนย. C 5 

PROCEDCODE รหสัมาตรฐาน ICD-9-CM หรือ ICD-10-TM (รหสัหตัถการ) Y C 7 

SERVICEPRICE ราคาค่าบริการหตัถการ มีทศนยิม 2 ตําแหนง่ N 11 

PROVIDER เลขทีผู้ให้บริการ ออกโดยโปรแกรม ไม่ซํากนัในสถานพยาบาลเดียวกัน C 15 

D_UPDATE วนัทีเพมิและปรับปรุงข้อมูล  กําหนดรูปแบบเป็น ปีเดือนวนัชัวโมงนาที

วนิาที (YYYYMMDDHHMMSS) และเป็นปีคริสตศกัราช 

DT 14 

การนําแฟม PROCEDURE_OPD เขาสูคลังขอมูลจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอน

ดังตอไปน้ี 

1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม ที่อยูบน 

toolbar.

2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “PROOPD”, ใน 

tab PROOPD พิมพขอความ “PROOPD:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ 

ขี้นบรรทัดใหมดังภาพหนาจอดานลาง
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3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ PROCEDURE_OPD ที่เก็บไวใน Folder ใดๆ 

เชนในที่น้ีอยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียด 

ของไฟล ถาเปด text file ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย หรือถาเปด 

excel file ใหตรวจสอบขอมูลใหเรียบรอย ดังภาพตอไป

4. แกไข Script ในหนา PROOPD ใหเปนดังตอไปน้ี

LOAD HOSPCODE&PID&SEQ AS OPDID,
DATE_SERV AS DATEPRO,
PROCEDCODE,
SERVICEPRICE AS PROPRICE

FROM
…

5. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชือมโยงตารางดงัภาพต่อไปนี
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บทท่ี 6   

การนับจํานวนและการวิเคราะหสัดสวน 
 

การนับจํานวนและการวิเคราะหความถี่เปนการวิเคราะหทางสถิติขั้นพื้นฐาน เราจะเริ่มดําเนินการวิเคราะหโดย

การนับจํานวนผูปวยตามลักษณะตางๆ โดยใชขั้นตอนดําเนินการดังตอไปน้ี 

 
1. สราง worksheet ใหม โดยการเลือก menu Layout => Add Sheet หรือกดปุม             ที่

ปรากฎอยูบน toolbar 

 
2. ตั้งชื่อ worksheet ใหมดายการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Sheet1 ใหกลายเปน Patient ดังภาพ

หนาจอดานลาง 

 

 
 
3. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar ดังภาพหนาจอตอไป 
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4. พิมพชื่อ “จํานวนผูปวยจําแนกตามเพศ” เขาไปในชอง Window Title ในหนาจอ General แลวเลือก

ภาพกราฟแทง (bar chart) ที่อยูในกรอบ Chart type ดังภาพตอไป แลวกดปุม Next 
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5. เลือก SEX จากชอง Available Fields/Groups แลวกดปุม Add เพื่อให SEX เขาไปอยูใน ชอง 

Used Dimensions ดังภาพดานลาง

6. กดปุม Next เพื่อเปดหนาตาง Edit Expression เลือก Total Count ในของ Aggregation แลว

เลือก AN ในชอง Field แลวคลิกเลือก Distinct ในชอง check box ดังภาพดานลาง

1. Select Total Count

2. Select ID

3. Select Distinct
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7. กดปุม Paste จะพบวามีชอความที่ใชแสดงคาในแกน Y ของกราฟแทง อยูในชอง Expression ดัง

ภาพดานลาง

8. กดปุม OK เพ่ือปดหนาตาง Edit Expression จะพบหนาตาง Expression ซึ่งแสดงสูตร Count 

(DISTINCT ID) อยูในชองดานบนซายและในชอง Definition ใหคลิกเลือกกลอง Value on Data 

Points ดังภาพตอไป

9. กดปุม Finish จะไดกราฟแทงที่แสดงจํานวนผูปวยจําแนกตามแผนกดังภาพตอไป
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10. กราฟแทงน้ีแสดง จํานวนผูปวยจําแนกตามเพศ 

 
ตอเปนเปนการวิเคราะหความถี่ โดยใชขั้นตอนดําเนินการดังตอไปน้ี 

  

1. คลิกขวาที่กราฟแทงแสดงเพศผูปวยแลวเลือก menu Clone ดังภาพดานลาง   
 

 
 
2. การ Clone จะสรางกราฟแทงใหมที่เหมือนกับกราฟเดิม เราจะใชกราฟแทงใหมน้ีแสดงความถี่ของ

จํานวนผูปวยในแตละเพศ คลิกขวาที่กราฟแทงใหมแลวปรับแตง Propertites ใน tab General ตั้งชื่อ

เปน สัดสวนของผูปวยในแตละเพศ ดังภาพตอไป  
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3. ไปที่ tab Expressions แลวคลิกเลือก กลอง Relative ที่อยูตรงกลาง Tab ดังภาพดานลาง  
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4. กดปุม OK เพื่อปดหนาตาง เราจะไดกราฟแทงที่สองแสดงสัดสวนผูปวยในแตละแผนกดังภาพดานลาง 
  

 
 
 
5. ตอไปลองเปล่ียนรูปแบบของกราฟโดยการปรับแตง Properties ใช tab General แลวเปล่ียนภาพ

ของกราฟเปนกราฟวงกลมดังภาพดานลาง 
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6. กดปุม OK เพื่อปดหนาตาง เราจะไดกราฟวงกลมแสดงสัดสวนผูปวยในแตละเพศดังภาพดานลาง 
  

 
 

7. ลองขยับ mouse ให cursor ไปอยูในสวนของวงกลม จะเห็นวาสวนที่เราชี้จะขยายออกแสดงขอมูลดัง

ภาพตอไป 
  

 
 
8. เราสามารถย่อ (minimize) กราฟทั้งหมดที่อยูใน worksheet ไดโดยการกดปุมรูป _ ที่มุมบนขวา

ของกราฟ โดยถากดปุม minimize กราฟวงกลมจะพบวา กราฟวงกลมจะยุบลงเหลือแตชื่อดังภาพ

ดานลาง 
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9. ถากราฟอยูในสถานะยอ (minimize) ภาพของกราฟจะแสดงอยูที่ขอบซายขางๆชื่อของกราฟน้ัน เรา

สามารถขยายกราฟไดดวยการ doulble click กราฟน้ัน 
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บทท่ี 7   

การวิเคราะหลําดับ (Ranking Analysis) 
 
การวิเคราะหลําดับเปนการวิเคราะหทางสถิติที่ใชบอยที่สุด ตัวอยางการวิเคราะหลักษณะน้ีไดแก 

 สถิติสาเหตุการตายที่พบมากที่สุด 10 อันดับแรก 

 สถิติโรคหลัก 5 อันดับแรก 

 สถิติแผนกที่ใหบริการผูปวยมากที่สุด 7 อันดับแรก 

 
เราสามารถใช Qlikview ชวยวิเคราะหลําดับไดอยางงายดาย โดยใชขั้นตอนดําเนินการดังตอไปน้ี 

 
1. สราง worksheet ใหม โดยการเลือก menu Layout => Add Sheet หรือกดปุม             ที่

ปรากฎอยูบน toolbar 

 
2. ตั้งชื่อ worksheet ใหมดายการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Sheet2 ใหกลายเปน Ranking 

Analysis   
  
3. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar   

  
4. พิมพชื่อ “สถิติโรคหลัก 10 อันดับแรก” หรือ Top 10 Principal Diagnosis เขาไปในชอง 

Window Title ในหนาจอ General แลวเลือกภาพกราฟแทง (bar chart) ที่อยูในกรอบ Chart 

type ดังภาพตอไป แลวกดปุม Next 

 
5. เลือก DIAG จากชอง Available Fields/Groups แลวกดปุม Add เพื่อให ICDIPD เขาไปอยูใน

ชอง Used Dimensions ดังภาพดานลาง 

 

Prepare to Click “Edit” 
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 6. กดปุม Edit เพื่อเปดหนาตาง Edit Expression เปล่ียนขอความสูตรจากคําวา ICDIPD ให

กลายเปนคําวา IF(ICDIPDTYPE=1, ICDIPD) ดังภาพดานลาง 

  

 
 
7. กดปุม Next เพื่อเปดหนาตาง Edit Expression เลือก Total Count ในของ Aggregation แลว

เลือก ANID ในชอง Field แลวคลิกเลือก Distinct ในชอง check box ดังภาพดานลาง 

 

 
 
8. กดปุม Paste จะพบวามีชอความที่ใชแสดงคาในแกน Y ของกราฟแทง อยูในชอง Expression ดัง

ภาพดานลาง 

 

1. Select Total Count 

2. Select ANID 

3. Select Distinct 
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9. กดปุม OK เพื่อปดหนาตาง Edit Expression จะพบหนาตาง Expression ซ่ึงแสดงสูตร Count 

(DISTINCT ANID) อยูในชองดานบนซายและในชอง Definition ใหคลิกเลือกกลอง Value on 

Data Points ดังภาพดานลาง 

  

 
 
10. กดปุม Next ไปที่หนาตาง Sort เลือก Sort by Y-value Desceding  ดังภาพดานลาง 
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11. กดปุม Next ไปที่หนาตาง Stype เปล่ียน Orientation style จากแนวตั้งใหเปนแนวนอน  ดังภาพ

ดานลาง 

  
 

 
 
12. กดปุม Finish จะไดกราฟแทงที่แสดงจํานวนรหัส ICD ที่เปนรหัสโรคหลัก เรียงตามจํานวนผูปวยจาก

มากไปหานอย ดังภาพดานลาง 
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13. คลิกขวาทีกราฟแทงเพื่อปรับแตง Properties ไปที่ tab Dimension Limits คลิกเลือกกลอง 

Restrict which values are displayed during the first expression แลวยกเลิกการเลือก

กลอง Show Others ดังภาพดานลาง 

  

 
 
14. ไปที่ tab Dimension คลิกกลอง Suppress When Value is Null ดังภาพดานลาง 

  

 
 

Check Here 

Check Here 

Uncheck Here 
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15. กดปุม Finish เราจะไดกราฟแทงที่แสดงจํานวนรหัส ICD ที่เปนรหัสโรคหลัก 10 อันดับ ดังภาพ

ดานลาง 

 

 
 
อยางไรก็ตามการแสดงขอมูลในกราฟแทงน้ียังมีขอผิดพลาดอยู โดยหากทานมีความรูเรื่องรหัส ICD-10 ก็คง

จะทราบวารหสั Z380 เปนรหัสสําหรับเด็กที่คลอดปกติในโรงพยาบาล เชนเดียวกันรหัส O800 ก็เปนรหัสสําหรับหญิง

ที่มาคลอดบุตรในโรงพยาบาลโดยไมมีโรคแทรกซอน ซ่ึงในกราฟแทงน้ี แสดงเหมือนกับวา ผูปวยสองกลุมน้ีเปนโรค ซ่ึง

จริงๆแลว ไมควรแสดงขอมูลผูปวยสองกลุมดังกลาวในกราฟน้ี 

เราควรแกไขใหกราฟแทงน้ี แสดงสถิติโรคจริงๆ โดยควรตัดกราฟแสดงผูปวยเด็กแรกเกิดและหญิงคลอดปกติ

ออกไป โดยใชขั้นตอนดังตอไปน้ี 

 
1. สร้างกราฟแท่งใหม่จากกราฟเดิม โดย คลิกขวาที่กราฟแทงแลวเลือก menu Clone     
 
2. ตั้งชื่อกราฟใหมเปน สถิติรหัสโรคหลักของผูปวยใน 10 อันดับแรก ไมรวมเด็กแรกเกิดและหญิงคลอดปกติ   
  
3. คลิกขวาที่กราฟแทงแลวปรับแตง Properties ไปที่ tab Dimesnsion ดังภาพตอไป 
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4. คลิกปุม Edit เพื่อเปดหนาตาง Edit Expression เปล่ียนขอความภายในใหม ดังภาพดานลาง   
  

=IF(ICDIPDTYPE=1 AND ICDIPD <>'Z830' AND ICDIPD <> 'O800' ,ICDIPD)  
 

 
 
 
5. กดปุม OK เพื่อปดหนาตาง Edit Expression แลว กดปุม OK อีกครั้งเพื่อปดหนาตาง Chart 

Properties   
  

 
 

Prepare to Click 
“Edit” 
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ในขณะน้ี เราจะมีกราฟแทงอันที่สองเพื่อใชแสดง สถิติรหัส ICD โรคหลักที่พบบอย 10 อันดับแรกที่ไมรวม

เด็กแรกเกิดและหญิงคลอดปกติ ซ่ึงสามารถใชแสดงขอมูลใหถูกตองตามความเปนจริงได

เราสามารถปรับแตง Properties ของกราฟเพื่อแสดง สถิติที่พบบอย 5, 20 อันดับแรก หรือ กําหนดตัวเลข

อ่ืนๆไดอยางงายดาย

การสรางตารางแสดงโรครวม โรคแทรก โรคอื่นๆ สาเหตุการบาดเจ็บในกรณีของผูปวยใน 

เราจะสรางตารางแสดงโรครวม โดยดึงขอมูลเฉพาะโรครวมจากแฟม DIAGNOSIS_IPD เขาสูคลังขอมูล

เพิ่มเติม โดยจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอนดังตอไปน้ี 

1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม ที่อยูบน 

toolbar.

2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “COMOR”, ใน

tab COMOR พิมพขอความ “COMOR:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter เพื่อ

ขี้นบรรทัดใหมดังภาพหนาจอดานลาง

3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ DIAGNOSIS_IPD ที่เก็บไวใน Folder ใดๆ เชน

ในที่นี้อยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียด



67 
 

ของไฟล ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย (ในกรณีเปด text file) ดังภาพ

ตอไป 

 

 
 
4. แกไข Script ในหนา COMOR ใหเปนดังตอไปน้ี 

COMOR: 
LOAD HOSPCODE&PID&AN AS ANID,  
     DIAGCODE AS COMOR 
      
FROM 
[C:\DataCenter\diagnosis_ipd.txt] 
(txt, codepage is 874, embedded labels, delimiter is '\t', msq) 
 
WHERE DIAGTYPE=2; 
  

 
5. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชือมโยงตารางดงัภาพต่อไปน ี
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6. ทําซํ้าขั้นตอน 1-5 อีก 3 ครั้ง เพื่อสรางตาราง COMP (นําเขา Complication, DIAGTYPE=3) 

สรางตาราง OTHER (นําเขา Other Diagnosis, DIAGTYPE=4) และตาราง EXT (นําเขา 

External Causes, DIAGTYPE=5)  
 

7. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชือมโยงตารางดงัภาพต่อไปน ี
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การสรางตารางแสดงโรคอื่นๆ ในกรณีของผูปวยนอก 
 

เราจะสรางตารางแสดงโรคอ่ืนๆของผูปวยนอก โดยดึงขอมูลเฉพาะโรคอ่ืนๆจากแฟม DIAGNOSIS_OPD 

เขาสูคลังขอมูลเพิ่มเติม โดยจะใชหนาจอ Edit Script ดําเนินการตามขั้นตอนดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “OPDOTH”, ใน 

tab OPDOTH พิมพขอความ “OPDOTH:” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter 

เพื่อขี้นบรรทัดใหมดังภาพหนาจอดานลาง 

 

 
 
3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ DIAGNOSIS_OPD ที่เก็บไวใน Folder ใดๆ 

เชนในที่น้ีอยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียด

ของไฟล ตั้งคา Delimiter เปน | และ Character Set เปนภาษาไทย (ในกรณีเปด text file) ดังภาพ

ตอไป 
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4. กดปุม Finish แลวแกไข Script ในหนา ICDOPD ใหเปนดังตอไปน้ี 

OPDOTH: 
LOAD HOSPCODE&PID&SEQ AS OPDID,  
     DIAGCODE AS ODXOTH  
      
FROM 
[C:\DataCenter\diagnosis_opd.txt] 
(txt, codepage is 874, embedded labels, delimiter is '|', msq) 
 
WHERE DIAGTYPE > 1;  
  

 
5. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชือมโยงตารางดงัภาพต่อไปน ี
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การสรางตารางรายละเอียดของสถานพยาบาล 
 

เราจะสรางตารางแสดงโรครวม โดยดึงขอมูลเฉพาะโรครวมจาก เขาสูคลังขอมูลเพิ่มเติม โดยจะใชหนาจอ 

Edit Script ดําเนินการตามขั้นตอนดังตอไปน้ี 

 
1. เปดหนาจอ Edit Script โดยการเลือก menu File => Edit Script… หรือกดปุม            ที่อยูบน 

toolbar. 
 
2. ที่หนาจอ Edit Script เลือก menu Tab => Add Tab, ตั้งชื่อ Tab ใหมเปน “HOSPITAL”, ใน 

tab HOSPITAL พิมพขอความ “HOSOPD” (ปดทายดวยเครื่องหมาย colon) แลวกดปุม Enter 

เพื่อขี้นบรรทัดใหมดังภาพหนาจอดานลาง 
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3. กดปุม “Table Files” ดานลาง แลวเลือกไฟลชื่อ healthcare.xlsx ที่เก็บไวใน Folder ใดๆ เชนใน

ที่น้ีอยูใน Folder ชื่อ C:\DataCenter แลวกดปุม Open เพื่อเปดหนาตางแสดงรายละเอียดของไฟล

ดังภาพตอไป

4. กดปุม Finish แลวแกไข Script ในหนา HOSPITAL ใหเปนดังตอไปน้ี
HOSOPD:
LOAD รหสัหน่วยงาน5หลกั AS OPDHOS,

ชือหน่วยงานบริการสุขภาพ AS OPDHOSNAME,
ประเภท AS OPDHOSTYPE,
รหสัอาํเภอ AS OPDHOSAMPUR

FROM
[C:\DataCenter\healthcare.xlsx]
(ooxml, embedded labels, table is HealthCare);

HOSADM:
LOAD รหัสหน่ วยงาน5หลัก AS HOSADM,

ชือหน่วยงานบริการสุขภาพ AS ADHOSNAME,
ประเภท AS ADHOSTYPE,
รหสัอาํเภอ AS ADHOSAMPUR

FROM
[C:\DataCenter\healthcare.xlsx]
(ooxml, embedded labels, table is HealthCare);

5. แกไข Script เพิ่มเติมในหนา Main ใหเปนดังตอไปน้ี

LOAD HOSPCODE AS HOSADM,
HOSPCODE&PID AS ID,
SEQ,
HOSPCODE&PID&AN AS ANID,
AN,
DATETIME_ADMIT,
……
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6. กดปุม OK เพื่อปดหนาตาง Edit Script กดปุ่ ม Save เพื่อบันทึกงานที่ทํามาแลว Reload ขอมูล

ทั้งหมดโดยการเลือก menu File => Reload หรือกดปุมรูป         ที่ปรากฏบน toolbar แล้ว

ตรวจสอบการเชือมโยงตารางดงัภาพต่อไปนี 
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บทท่ี 8   

การวิเคราะหความผิดพลาดของการใหรหัส (ICD Coding Error Analysis) 
 

การวิเคราะหความผิดพลาดของการใหรหัส เปนการตรวจสอบความผิดพลาด 13 หัวขอ ตามหลักเกณฑการ

ตรวจสอบความผิดพลาดการใหรหัส ICD ในสถานพยาบาลของสํานักนโยบายและยุทธศาสตร กระทรวงสาธารณสุข ป 

พ.ศ. 2558 

 
ในบทน้ี เราจะฝกการใช Qlikview ชวยวิเคราะหความผิดพลาดของการใหรหัส ICD ในคลังขอมูล โดยใช

ขั้นตอนดําเนินการดังตอไปน้ี 

 
1. สราง worksheet ใหม โดยการเลือก menu Layout => Add Sheet หรือกดปุม             ที่

ปรากฎอยูบน toolbar 

 
2. ตั้งชื่อ worksheet ใหมดายการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Sheet3 ใหกลายเปน ErrorA1A2OPD 

  
3. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar   

  
4. พิมพชื่อ “ความผิดพลาด A1A2 ใน OPD” เขาไปในชอง Window Title ในหนาจอ General แลว

เลือกภาพตาราง (Straight Table) ที่อยูในกรอบ Chart type ดังภาพตอไป  
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5. กดปุม Next เลือก DIAG จากชอง Available Fields/Groups แลวกดปุม Add เพื่อให ICDIPD 

เขาไปอยูในชอง Used Dimensions ดังภาพดานลาง 

 
 

6. กดปุม Next แลวพิมพขอความดานลางเชาไปอยูในชอง Edit Expression 

 
Count ( {$<ICDOPD={"B260"}+{"C60*"}+{"C61*"}+{"C62*"}+{"C63*"}+{"D074"}+{"D075"} 
+{"D076"}+{"D176"}+{"D29*"}+{"D40*"}+{"E29*"}+{"E895"}+{"F524"}+{"I861"} 
+{"L291"}+{"N40"}+{"N41"}+{"N42*"}+{"N43*"}+{"N44*"}+{"N45*"}+{"N46*"}+{"N47*"}+
{"N48*"}+{"N49*"}+{"N50*"}+{"N51*"}+{"Q53*"}+{"Q54*"}+{"Q55*"}+{"R86*"}+{"S312"}
+{"S313"}+{"Z125"},SEX={"2"}> } DISTINCT OPDID)  
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7. กดปุม OK แลวพิมพขอความ A1 เขาไปในชอง Label ดังภาพตอไป 

 

 
 

8. กดปุม Add แลวพิมพขอความดานลางเชาไปอยูในชอง Edit Expression 

 
Count ( {$<ICDOPD={"A34*"}+{"B373"}+{"C51*"}+{"C52*"}+{"C53*"}+{"C54*"}+{"C55*"} 
+{"C56*"}+{"C57*"}+{"C58*"}+{"C796"}+{"D06*"}+{"D070"}+{"D071"}+{"D072"} 
+{"D073"}+{"D25*"}+{"D26*"}+{"D27*"}+{"D28*"}+{"D39*"}+{"E28*"}+{"E894"}+ 
{"F525*"}+{"F53*"}+{"I863"}+{"L292"}+{"L705"}+{"M800*"}+{"M801*"}+{"M810*"} 
+{"M811*"}+{"M830*"}+{"N70*"}+{"N71*"}+{"N72*"} +{"N73*"}+{"N74*"}+{"N75*"} 
+{"N76*"}+{"N77*"} +{"N78*"}+{"N79*"}+{"N80*"}+{"N81*"}+{"N82*"}+{"N83*"} 
+{"N84*"}+{"N85*"}+{"N86*"}+{"N87*"}+{"N88*"}+{"N89*"}+{"N90*"}+{"N91*"}+ 
{"N92*"}+{"N93*"}+{"N94*"}+{"N95*"}+{"N96*"}+{"N97*"}+{"N98*"}+{"N992"}+{"N993"} 
+{"O*"}+{"P546"}+{"Q50*"}+{"Q51*"}+{"Q52*"}+{"R87"}+{"S314*"}+{"S374*"}+ 
{"S375*"}+{"S376*"}+{"T192"}+{"T193"}+{"T833"}+{"Y76*"}+{"Z014"}+{"Z124"}+ 
{"Z301"}+{"Z303"}+{"Z305"}+{"Z311"}+{"Z312"}+{"Z32*"}+{"Z33*"}+{"Z34*"}+{"Z35*"}
+{"Z36*"}+{"Z39*"}+{"Z437"}+{"Z875"}+{"Z975"}, SEX={"1"}> } DISTINCT OPDID)  
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9. กดปุม OK แลวพิมพขอความ A2 เขาไปในชอง Label ดังภาพตอไป 

 

 
 

10. ทําซํ้าขั้นตอนที่ 9-10 อีก 3 รอบ เพื่อเพิ่ม Expression อีก 3 รายการ โดยมีรายละเอียดคือ 

 Expression Label = จํานวนผูปวยทั้งหมด ; Definition = Count(DISTINCT OPDID) 

 Expression Label = RateA1 ตอแสน ; Definition = A1/จํานวนผูปวยทั้งหมด*100000 

 Expression Label = RateA2 ตอแสน ; Definition = A2/จํานวนผูปวยทั้งหมด*100000 

ใหไดผลลัพธดังภาพตอไป 
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11. กดปุม Finish จะไดตารางในภาพตอไป 

 

 
 
12. คลิกขวาแลวปรับแตง Properties ดาน Number ของตาราง เลือก Expression A1 ปรับ 

Number Format Setting เปน Integer แลวทําซํ้ากับ A2, จํานวนผูปวยทั้งหมด ตอจากน้ันเลือก 

Expression RateA1 ตอแสน ปรับ Number Format Settings เปน Fixed to 2 Decimal 

แลวทําซํ้ากับ Expression RateA2 ตอแสน ดังภาพตอไป 
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13. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Table Box หรือกด

ปุมรูป           ที่อยูบน toolbar ในชอง Title ใสขอความ “รายละเอียด Case” แลวเพิ่ม Fields เขา

สูตารางดังภาพตอไป 

 

 
 

14. จัดรูปแบบและวางตารางไวดานขวาของตารางแรก ดังภาพตอไป ถาเราคลิกเลือกรายชื่อโรงพยาบาลจาก

ตารางแรก รายละเอียดของผูปวยของโรงพยาบาลน้ันจะปรากฏในตารางที่สองน้ี 

 

 
 

15. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar   
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16. พิมพชื่อ “Error A1A2 จําแนกตามสถานพยาบาล” เขาไปในชอง Window Title ในหนาจอ 

General แลวเลือกกราฟแทง (Bar chart) ที่อยูในกรอบ Chart type ดังภาพตอไป  

 

 
 

17. กดปุม Next ไปหนา Dimension เลือก OPDHOSNAME ดังภาพตอไป  
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18. กดปุม Next ไปหนา Edit Expression พิมพขอความดานลางเขาไป ดังภาพตอไป  

 
Count ({$ <ICDOPD={"B260"}+{"C60*"}+{"C61*"}+{"C62*"}+{"C63*"}+{"D074"}+{"D075"} 
+{"D076"}+{"D176"}+{"D29*"}+{"D40*"}+{"E29*"}+{"E895"}+{"F524"}+{"I861"}+ 
{"L291"}+{"N40"}+{"N41"}+{"N42*"}+{"N43*"}+{"N44*"}+{"N45*"}+{"N46*"}+{"N47*"} 
+{"N48*"}+{"N49*"}+{"N50*"}+{"N51*"}+{"Q53*"}+{"Q54*"}+{"Q55*"}+{"R86*"} 
+{"S312"}+{"S313"} +{"Z125"},SEX={"2"}> } DISTINCT OPDID)  

 

 
 

19. กดปุม OK ไปที่หนา Expression พิมพขอความ OPDA1Error เขาในชอง Label แลวคลิกเลือก 

Value on Data Points ดังภาพตอไป  
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20. กดปุม Next ไปที่หนา Sort แลวคลิกเลือก Sort by Y-value ดังภาพตอไป  

 

 
 

21. กดปุม Next ไปที่หนา Style แลวคลิกเลือก Orientation เปนกราฟแนวนอน ดังภาพตอไป 
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22. กดปุม Next ไปที่หนา Presentation แลวคลิกเลือก Enable X-Axis Scrollbar กําหนดตัวเลข

ในชอง When Number of Items Exceeds เปนเลข 10 ดังภาพตอไป 

 

 
 

23. กดปุม Next สองครั้งไปที่หนา Colors เลือก Multicolored ดังภาพตอไป 

 

 
 

24. กดปุม Finish จะไดกราฟแสดงสถานพยาบาลที่เกิดความผิดพลาดที่ OPD แบบ A1 ดังภาพตอไป 
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25. จัดวางตําแหนงของกราฟอยูดานชวาสุด ดังภาพตอไป  

 

 
 

26. Clone กราฟแทงโดยคลิกขวาแลวเลือกเมนู ดังภาพตอไป  
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26. ตั้งชื่อกราฟที่ Clone มาใหชื่อใหมเปน  ErrorA2 จําแนกตามสถานพยาบาล แลวปรับแตงคุณสมบัติ 

Expression แกไขขอความใน Expression ตามขอความดานลางดังภาพตอไป 

 
Count ( {$ 
<ICDOPD={"A34*"}+{"B373"}+{"C51*"}+{"C52*"}+{"C53*"}+{"C54*"}+{"C55*"}+{"C56*"} 
+{"C57*"}+{"C58*"}+{"C796"}+{"D06*"}+{"D070"}+{"D071"}+{"D072"}+{"D073"}+{"D25*"
}+{"D26*"}+{"D27*"}+{"D28*"}+{"D39*"}+{"E28*"}+{"E894"}+{"F525*"}+{"F53*"} 
+{"I863"} +{"L292"}+{"L705"} +{"M800*"}+{"M801*"}+{"M810*"}+{"M811*"} +{"M830*"} 
+{"N70*"}+{"N71*"} +{"N72*"}+{"N73*"}+{"N74*"}+{"N75*"}+{"N76*"} +{"N77*"} 
+{"N78*"} +{"N79*"} +{"N80*"}+{"N81*"}+{"N82*"}+{"N83*"}+{"N84*"} 
+{"N85*"}+{"N86*"} +{"N87*"}+{"N88*"} +{"N89*"}+{"N90*"}+{"N91*"}+{"N92*"} 
+{"N93*"}+{"N94*"}+{"N95*"}+{"N96*"}+{"N97*"}+{"N98*"}+{"N992"}+{"N993"} 
+{"O*"}+{"P546"}+{"Q50*"}+{"Q51*"}+{"Q52*"}+{"R87"}+{"S314*"}+{"S374*"} 
+{"S375*"}+{"S376*"}+{"T192"}+{"T193"}+{"T833"}+{"Y76*"}+{"Z014"}+{"Z124"} 
+{"Z301"}+{"Z303"}+{"Z305"}+{"Z311"}+{"Z312"}+{"Z32*"}+{"Z33*"} 
+{"Z34*"}+{"Z35*"}+{"Z36*"}+{"Z39*"}+{"Z437"}+{"Z875"}+{"Z975"}, SEX={"1"}> } 
DISTINCT OPDID)   

 

 
 

27.  กดปุม OK แลวจัดตําแหนงใหเหมาะสม ดังภาพตอไป 
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28. สราง object ใหม โดยเลือก menu Object => New Sheet Object => List Box หรือกดปุม

รูป           ที่อยูบน toolbar ในชอง Title ใสขอความ “ICD เฉพาะเพศชาย” ดังภาพตอไป 

 

 
 

29.  ไปที ่Tab Expressions กดปุม Add แลวพิมพขอความดานลางเขาไปในชอง Edit Expression 

ดังภาพตอไป 
 
=IF(ICDOPD= 'B260' OR (ICDOPD >= 'C600' AND ICDOPD <= 'C639') OR ICDOPD= 'D074' 
OR ICDOPD= 'D075' OR ICDOPD= 'D076' OR ICDOPD= 'D176' OR (ICDOPD >= 'D290' AND 
ICDOPD <= 'D299') OR (ICDOPD>= 'D400' AND ICDOPD <= 'D409') OR (ICDOPD>= 'E290' 
AND ICDOPD <= 'E299') OR ICDOPD= 'E895' OR ICDOPD= 'F524' OR ICDOPD= 'I861' OR 
ICDOPD = 'L291' OR ICDOPD= 'N40' OR ICDOPD= 'N41' OR (ICDOPD>= 'N420' AND ICDOPD 
<='N519')  OR (ICDOPD >= 'Q530' AND ICDOPD<='Q559') OR (ICDOPD >= 'R860' AND 
ICDOPD <='R869') OR ICDOPD= 'S312' OR ICDOPD= 'S313' OR ICDOPD= 'Z125' , ICDOPD) 
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30.  กดปุม OK จะได List Box แสดงรายการรหัส ICD เฉพาะเพศชาย ดังภาพตอไป 

 
 

31.  ทําซํ้าขั้นตอนที่ 28-30 เพื่อสราง List Box แสดงรายการรหัส ICD เฉพาะเพศหญิง โดยกําหนด 

Expression ดวยขอความดานลาง ดังภาพตอไป 

 
=IF ((ICDOPD>='A340' AND ICDOPD<='A349') OR ICDOPD='B373' OR (ICDOPD>='C510' AND 
ICDOPD<='C589') OR ICDOPD='C796' OR (ICDOPD>='D060' AND ICDOPD <='D069') OR 
ICDOPD='D070' OR ICDOPD='D073' OR (ICDOPD>='D250' AND ICDOPD<='D289') 
OR (ICDOPD>='D390' AND ICDOPD <='D399') OR (ICDOPD>='E280' AND ICDOPD <='E289') 
OR ICDOPD='E894' OR (ICDOPD>='F525' AND ICDOPD <='F5259') OR (ICDOPD >='F53' AND 
ICDOPD <='F539') OR ICDOPD='I863' OR ICDOPD='L292' OR ICDOPD='L705' OR  
(ICDOPD>='M800' AND ICDOPD<='M8019') OR (ICDOPD>='M810' AND ICDOPD<='M8119') OR 
ICDOPD='M830' OR (ICDOPD>='N70' AND ICDOPD<='N989') OR ICDOPD='N992' OR 
ICDOPD='N993'OR (ICDOPD>='O00' AND ICDOPD <='O999') OR ICDOPD='P546' OR 
(ICDOPD>='Q50' AND ICDOPD='Q529') OR ICDOPD='R87' OR (ICDOPD>='S314' AND ICDOPD 
<'S3149') OR (ICDOPD>='S374' AND ICDOPD='S3769') OR ICDOPD='T192' OR 
ICDOPD='T193' OR ICDOPD='T833' OR (ICDOPD>='Y76' AND ICDOPD <='Y7699') OR 
ICDOPD='Z014' OR ICDOPD='Z124' OR ICDOPD='Z301' OR ICDOPD='Z303' 
OR ICDOPD='Z305' OR ICDOPD='Z311' OR ICDOPD='Z312' OR (ICDOPD>='Z32' AND 
ICDOPD<='Z369') OR (ICDOPD>='Z39' AND ICDOPD <='Z399') OR ICDOPD='Z437' OR 
ICDOPD='Z875' OR ICDOPD='Z975'  , ICDOPD)  

 

 
 

32. สราง object ใหม โดยเลือก menu Object => New Sheet Object => List Box หรือกดปุม

รูป           ที่อยูบน toolbar ในชอง Field เลือก SEX ดังภาพตอไป 
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33. กดปุม OK จะได List Box ที่แสดงเพศ ใชเลือกเพศที่ตองการ 

34. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Current 

Selection Box หรือกดปุมรูป           ที่อยูบน toolbar เพื่อเปดกรอบโตตอบ ดังภาพตอไป 

 

 
 

35. กดปุม OK จะได Current Selection Box ใชแสดงรายการที่เลือกดูอยูในปจจุบัน จัดวางตําแหนงไว

ดานลางซายของแผนงาน ดังภาพตอไป 
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36. เราสามารถใชแผนงานน้ี คนหารายละเอียด Case ที่ผิดพลาดได โดยถาตองการดูการใหรหัส ICD เพศ

หญิงในผูปวยชาย ใหเลือก List Box ICD เฉพาะหญิง โดยคลิกขวาที่ List Box แลวเลือกรายการ

ทั้งหมด (Select All) ตอจากน้ันเลือกเพศชายใน List Box SEX รายละเอียดของ Case จะปรากฏใน

ตารางตอนกลาง ซ่ึงเราสามารถสงออกเปน Excel file โดยกดที่ปุม XL ดานบนขวาของตาราง ดังภาพ

ตอไป 
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Error A1 และ A2 ที่พบในผูปวย IPD 

 
ตอไปน้ี เปนการวิเคราะหความผิดพลาดของการใหรหัส ICD แบบ A1 และ A2 ที่พบในผูปวยใน โดยใช

ขั้นตอนดําเนินการดังตอไปน้ี 

 
1. คัดลอก worksheet ErrorA1A2OPD เพื่อสราง worksheet ใหม ดวยการคลิกขวาที่สวนหัวของ 

worksheet แลวเลือก เมนู Copy Sheet ดังภาพตอไป 

 

 
 
2. ตั้งชื่อ worksheet ใหมดวยการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Copy of ErrorA1A2OPD ให

กลายเปน ErrorA1A2IPD 

 
3. แผนงานน้ีใชแสดงความผิดพลาดแบบ A1 และ A2 ที่พบในผูปวย IPD เราจึงตองแกไขการแสดงผล

ทั้งหมดในทุกๆตารางและกราฟ ใหแสดงผลจากขอมูล IPD เริ่มจากการปรับแตงตารางแรกดานซายบน

ดวยการคลิกขวาเลือกเมนู Properties ดังภาพตอไป 
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4. เปล่ียนชื่อตารางใหเปน “ความผิดพลาด A1,A2 ใน IPD” แลวไปที่ Tab Dimensions เปล่ียน

รายการในชอง Used Dimensions จากเดิม OPDHOSNAME ใหกลายเปน ADHOSNAME 

ดังภาพตอไป 

 

 
 
5. ไปที่ Tab Expression เปล่ียน Definition ของคอลัมน A1 ใหแสดงผลจากรหัส IPD โดยนับตาม 

ANID ดังภาพตอไป 

 

 
 

6. ไปที่ Tab Expression เปล่ียน Definition ของคอลัมน A2 ใหแสดงผลจากรหัส IPD โดยนับตาม 

ANID ดังภาพตอไป 

 

 
 

7. กดปุม OK ปดหนาตาง Edit Expression และ กดปุม OK อีกครั้ง เสร็จการปรับแตงตารางแรก 
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8. ปรับแตงคุณสมบัติของตารางตอไป คือตารางรายละเอียด Case คลิกขวาที่ตารางแลวเลือกเมนู 

Properties ดังภาพตอไป 

 

 
 

9. ไปที่ Tab General ในชอง Fields Displayed inTablebox เปล่ียนแปลงรายการ ดังภาพตอไป 

 

 
 

10. กดปุม OK แลวปรับขนาดของคอลัมนใหเหมาะสม ดังภาพตอไป 
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11. ปรับแตงคุณสมบัติของ กราฟ Error A1-OPD จําแนกตามสถานพยาบาล คลิกขวาที่กราฟแลวเลือก

เมนู Properties ดังภาพตอไป 

 

 
 

12. เปล่ียนชื่อกราฟเปน “Error A1-IPD จําแนกตามสถานพยาบาล” แลวปรับแตง Dimensions ใหใช 

ADHOSNAME แลวปรับแตง Expression ดังน้ี 

 
Count ({$ <ICDIPD={"B260"}+{"C60*"}+{"C61*"}+{"C62*"}+{"C63*"}+{"D074"}+{"D075"} 
+{"D076"}+{"D176"}+{"D29*"}+{"D40*"}+{"E29*"}+{"E895"}+{"F524"}+{"I861"}+ 
{"L291"}+{"N40"}+{"N41"}+{"N42*"}+{"N43*"}+{"N44*"}+{"N45*"}+{"N46*"}+{"N47*"} 
+{"N48*"}+{"N49*"}+{"N50*"}+{"N51*"}+{"Q53*"}+{"Q54*"}+{"Q55*"}+{"R86*"} 
+{"S312"}+{"S313"} +{"Z125"},SEX={"2"}> } DISTINCT ANID) 
  

 
13. กดปุม OK เพื่อเสร็จส้ินการปรับแตงกราฟ 

14. ทําการปรับแตงโดยใชหลักการเดียวกัน ในวัตถุตางๆที่เหลือดังน้ี 

 
Object การปรับแตง 

กราฟ Error A2 เปล่ียนชื่อ, เปล่ียน Dimension, แกไข Expression 

Listbox ICD เฉพาะชาย แกไข Expression (เปล่ียน ICDOPD เปน ICDIPD) 

Listbox ICD เฉพาะหญิง แกไข Expression (เปล่ียน ICDOPD เปน ICDIPD) 

 

15. เราสามารถใชแผนงานน้ี คนหารายละเอียด Case ที่ผิดพลาดได โดยถาตองการดูการใหรหัส ICD เพศ

หญิงในผูปวยชาย ใหเลือก List Box ICD เฉพาะหญิง โดยคลิกขวาที่ List Box แลวเลือกรายการ

ทั้งหมด (Select All) ตอจากน้ันเลือกเพศชายใน List Box SEX รายละเอียดของ Case จะปรากฏ

ในตารางตอนกลาง ลักษณะเชนเดียวกับการใชงานแผนงาน ErrorA1A2OPD 
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Error B1 ที่พบในผูปวย OPD 

 
ตอไปน้ี เปนการวิเคราะหความผิดพลาดของการใหรหัส ICD แบบ B1 ที่พบในผูปวย OPD โดยใชขั้นตอน

ดําเนินการดังตอไปน้ี 

 
1. คัดลอก worksheet ErrorA1A2OPD เพื่อสราง worksheet ใหม ดวยการคลิกขวาที่สวนหัวของ 

worksheet แลวเลือก เมนู Copy Sheet ดังภาพตอไป 

 

 
 
2. ตั้งชื่อ worksheet ใหมดวยการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title จากเดิมคือ Copy of ErrorA1A2OPD ให

กลายเปน ErrorB1OPD 

 
3. แผนงานน้ีใชแสดงความผิดพลาดแบบ B1 ที่พบในผูปวย OPD เราจึงตองปรับแตงตารางแรกดานซายบน

ดวยการคลิกขวาเลือกเมนู Properties ดังภาพตอไป 
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4. เปล่ียนชื่อตารางใหเปน “ความผิดพลาด B1 ใน รพ.สต.” แลวไปที่ Tab Dimensions เปล่ียนรายการ

ในชอง Used Dimensions โดยกดปุม Edit ดังภาพตอไป 

 

 
 

5. ในหนาจอ Edit Expression แกไขขอความ เพื่อใหแสดงรายการเฉพาะสถานพยาบาลที่เปน รพ.สต. 

(รหัสประเภทสถานพยาบาล = 18) ดังภาพตอไป 

 

 
 

6. กดปุม OK แลวพิมพขอความ “รายชื่อรพ.สต.” ในชอง Label ดังภาพตอไป 
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7. ไปที่ Tab Expression ปรับแตง Expressions ใหเหลือ 3 รายการ ดังภาพตอไป 

 

 
 

 8. แกไขคุณสมบัติ Expressions ทั้ง 3 รายการ ใหมีรายละเอียดดังน้ี 

 
Expression Definition 
จํานวนรหัส Z 

ที่ไมใชคัดกรอง 

Count ( {$ 
<ODXOTH={"Z0*"}+{"Z10*"}+{"Z14*"}+{"Z15*"}+{"Z16*"}+{"Z17*
"}+{"Z18*"}+{"Z19*"}+{"Z2*"}+{"Z3*"}+{"Z4*"}+{"Z5*"}+{"Z6*
"}+{"Z7*"}+{"Z8*"}+{"Z9*"}, ICDOPDTYPE={"1"}, 
ICDOPD={"A*"}+{"B*"}+{"C*"}+{"D*"}+{"E*"}+{"F*"} 
+{"G*"}+{"H*"}+{"I*"}+{"J*"}+{"K*"}+{"L*"}+{"M*"}+{"N*"}+ 
{"O*"}+{"P*"}+{"Q*"}+{"R*"}+{"S*"}+{"T*"}+{"U*"}> } 
DISTINCT OPDID)  

จํานวนผูปวย

ทั้งหมด 

Count ( {$ <ICDOPDTYPE={"1"}, ICDOPD={"A*"}+{"B*"} 
+{"C*"}+{"D*"}+{"E*"}+{"F*"}+{"G*"}+{"H*"}+{"I*"}+{"J*"}+ 
{"K*"}+{"L*"}+{"M*"}+{"N*"}+{"O*"}+{"P*"}+{"Q*"} 
+{"R*"}+{"S*"}+{"T*"}+{"U*"}> } DISTINCT OPDID)  
 

รอยละ [จาํนวนรหสั Z ทีไม่ใช่คดักรอง]/จาํนวนผูป่้วยทงัหมด 

 

 9. ไปที่ Tab Number ปรับแตงการแสดงผล จํานวนรหัสและจํานวนผูปวยเปนแบบ Interger และ

รอยละเปนทศนิยม 2 ตําแหนงดังภาพตอไป 
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 10.  กดปุม OK ปรับแตงคุณสมบัติของ กราฟ Error A1-OPD จําแนกตามสถานพยาบาล คลิกขวาที่

กราฟแลวเลือกเมนู Properties ดังภาพตอไป 

 

 
 

12. เปล่ียนชื่อกราฟเปน “Error B1-OPD จําแนกตามสถานพยาบาล” แลวปรับแตง Dimensions 

ดังน้ี 
 
=IF(Left(OPDHOSTYPE,2)='18', OPDHOSNAME)  

 

12. ปรับแตง Expression ดังน้ี 

 
Count ( {$ <ODXOTH={"Z0*"}+{"Z10*"}+{"Z14*"}+{"Z15*"}+{"Z16*"}+{"Z17*"} 
+{"Z18*"}+{"Z19*"}+{"Z2*"}+{"Z3*"}+{"Z4*"}+{"Z5*"}+{"Z6*"}+{"Z7*"}+{"Z8*"} 
+{"Z9*"}, ICDOPDTYPE={"1"}, ICDOPD={"A*"}+{"B*"}+{"C*"}+{"D*"}+{"E*"}+{"F*"} 
+{"G*"}+{"H*"}+{"I*"}+{"J*"}+{"K*"}+{"L*"}+{"M*"}+{"N*"}+{"O*"}+{"P*"}+{"Q*"} 
+{"R*"}+{"S*"}+{"T*"}+{"U*"}> } DISTINCT OPDID)  

  
13. กดปุม OK เพื่อเสร็จส้ินการปรับแตงกราฟ 

14. ลบ กราฟที่เหลือ (Error A2) ทิ้งไป โดยการคลิกขวาแลวเลือกเมนู Remove 

 
 
15. ทําการปรับแตงโดยใชหลักการเดียวกัน ในวัตถุตางๆที่เหลือดังน้ี 

 
Object การปรับแตง 

Listbox ICD เฉพาะชาย เปล่ียนชื่อเปน “รหัส ICD” แลวแกไข Expression เปน 
=IF(ICDOPD>'A' AND ICDOPD <'V00', 
ICDOPD) 
และปรับแตงการเรียง Sort by Text A-Z 

Listbox ICD เฉพาะหญิง เปล่ียนชื่อเปน “รหัส Z อ่ืน” แกไข Expression เปน 
=IF((ODXOTH>'Z00' AND ODXOTH 
<'Z11') OR ODXOTH > 'Z139', 
ODXOTH) และปรับแตงการเรียง Sort by Text A-Z  
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Object การปรับแตง 

Listbox SEX เปล่ียน Field ที่แสดงผลจาก SEX เปล่ียนเปน 

ICDOPDTYPE 
ตารางรายละเอียด Case เปล่ียน Field ที่แสดงผลจาก SEX เปล่ียนเปน 

ODXOTH 
 

 
16. เราสามารถใชแผนงานน้ี คนหารายละเอียด Case ที่ผิดพลาดได โดยคลิกขวาที่ List Box รหัส ICD 

แลวเลือกรายการทั้งหมด (Select All) ตอจากน้ันคลิกขวา List Box รหัส Z อ่ืนๆ แลวเลือกรายการ

ทั้งหมด (Select All) รายละเอียดของ Case ที่ผิดพลาด จะปรากฏในตารางตอนกลาง ลักษณะ

เชนเดียวกับการใชงานแผนงานอ่ืนๆ   

 
 
 
ฝกปฎิบัติบทท่ี 8 : สรางแผนงานเพ่ิมเติมเพ่ือแสดง 

 
8.1 Error B2 ถึง B10 โดยมีรายละเอียด คําสั่งคนหาดังน้ี 

 
B2OPD Count ( {$ <ICDOPD={"V*"}+{"W*"}+{"X*"}+{"Y*"}, 

ICDOPDTYPE ={"1"}> } DISTINCT OPDID) 
B2IPD Count ( {$ <ICDIPD={"V*"}+{"W*"}+{"X*"}+{"Y*"}, 

ICDIPDTYPE ={"1"}> } DISTINCT ANID) 

B3OPD Count ( {$ <ICDOPD={"S*"}+{"T*"}> } DISTINCT OPDID)  
- Count( {$ <ICDOPD={"S*"}+{"T*"}, ODXOTH = 
{"V*"}+{"W*"}+{"X*"}+{"Y*"}>} DISTINCT OPDID) 

B3IPD Count ( {$ <ICDIPD={"S*"}+{"T*"}> } DISTINCT ANID)  
- Count( {$ <ICDIPD={"S*"}+{"T*"}, ICDEXT = 
{"V*"}+{"W*"}+{"X*"}+{"Y*"}>} DISTINCT ANID) 

B4OPD Count ( {$ 
<ICDOPD={"Z23*"}+{"Z24*"}+{"Z25*"}+{"Z26*"}+{"Z27*"}, 
ODXOTH={"Z00*"}+{"Z01*"}+{"Z02*"} > } DISTINCT OPDID) 

B5OPD Count ( {$ 
<PROCEDCODE={"9018170"}+{"9038170"}+{"9088170"}> } 
DISTINCT OPDID)   

B6OPD Count ( {$ <ICDOPD={"*"}, ODXOTH={"Z768"}> } DISTINCT 
OPDID)   

B7IPD Count ( {$ <ICDOPD={"*"}, ODXOTH={"Z768"}> } DISTINCT 
OPDID)   

B8OPD Count ( {$ <ICDOPD={"T31*"},ICDOPDTYPE={"1"}> } 
DISTINCT OPDID)   

B8IPD Count ( {$ <ICDIPD={"T31*"},ICDIPDTYPE={"1"}> } 
DISTINCT ANID)   

B9OPD Count ( {$ <ICDOPD={"V*"}+{"W*"}+{"X"}+{"Y"}-
{"V????"}-{"W????"}-{"X????"}-{"Y1???"}-{"Y2???"}-
{"Y30??"}-{"Y31??"} 
-{"Y32??"}-{"Y33??"}-{"Y34??"}> } DISTINCT OPDID) 



99 
 

 
B9IPD Count ( {$ <ICDIPD={"V*"}+{"W*"}+{"X"}+{"Y"}-{"V????"}-

{"W????"}-{"X????"}-{"Y1???"}-{"Y2???"}-{"Y30??"}-{"Y31??"} 
-{"Y32??"}-{"Y33??"}-{"Y34??"}> } DISTINCT ANID)   
B10 OPD 

Count ( {$ <ICDOPD={"S*"}+{"T*"},ICDOPDTYPE={"1"}, ODXOTH 
={"Z47*"}+{"Z48*"}> } DISTINCT OPDID) 
+ Count ( {$ <ICDOPD={"Z47*"}+{"Z48*"},ICDOPDTYPE={"1"}, 
ODXOTH ={"S*"}+{"T*"}> } DISTINCT OPDID) 

B10IPD Count ( {$ <ICDIPD={"S*"}+{"T*"},ICDIPDTYPE={"1"}, ICDCOMOR 
={"Z47*"}+{"Z48*"}> } DISTINCT ANID)  
+ Count ( {$ <ICDIPD={"Z47*"}+{"Z48*"},ICDIPDTYPE={"1"}, 
ICDCOMOR ={"S*"}+{"T*"}> } DISTINCT ANID) 

 

8.2 Error C1 และ C2 โดยมีรายละเอียด คําสั่งคนหาดังน้ี 

 
C1OPD Count ( {$ 

<ICDOPD={"J069"}+{"D229"}+{"L029"}+{"L039"}+{"T07*"}+{"T14*"}> 
} DISTINCT OPDID) 

C1IPD Count ( {$ 
<ICDIPD={"J069"}+{"D229"}+{"L029"}+{"L039"}+{"T07*"}+{"T14*"}> 
} DISTINCT ANID) 

 
 
การทํารายงานสรุปแยกตามอําเภอและสถานพยาบาล 

 
ตอไปน้ี เปนการสรางตารางสรุปความผิดพลาดของการใหรหัสผูปวย OPD จําแนกตามอําเภอและ

สถานพยาบาลในแตละอําเภอ โดยใชขั้นตอนดําเนินการดังตอไปน้ี 

 
1. สราง worksheet ใหม โดยการเลือก menu Layout => Add Sheet หรือกดปุม             ที่

ปรากฎอยูบน toolbar 

 
2. ตั้งชื่อ worksheet ใหมดายการคลิกขวาที่ worksheet เลือก menu Properties… ปรับแตง

คุณลักษณะใน tab General เปล่ียนชื่อ Title ใหกลายเปน Report by Amphur - OPD 

  
3. สราง object ใหม โดยเลือก menu Object => New Sheet Object => Chart หรือกดปุม                         

รูป           ที่อยูบน toolbar   

  
4. พิมพชื่อ “รายงานความผิดพลาดการใหรหัส ICD ในผูปวย OPD จําแนกตามอําเภอ” เขาไปในชอง 

Window Title ในหนาจอ General แลวเลือกภาพตาราง (Pivot Table) ที่อยูในกรอบ Chart 

type ดังภาพตอไป  
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5. กดปุม OK กําหนด Dimension รวม 3 Dimensions คือ  OPDHOSAMPUR, OPDHOS 

และ OPDHOSNAME ดังภาพตอไป  

 

 
 
 

6. กดปุม Next ไปที่หนา Edit Expression พิมพขอความ ดังภาพตอไป  
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7. กดปุม OK แลวพิมพขอความ “จํานวนผูปวย” ในชอง Label  

 
8. กดปุม Add เพิ่ม Expression อีก 13 รายการ ดังรายละเอียด 

 
Label Expression 
ErrorA1 คําส่ังที่นับจํานวน Error A1 ใน OPD 

ErrorA2 คําส่ังที่นับจํานวน Error A2 ใน OPD 

ErrorB1 คําส่ังที่นับจํานวน Error B1 ใน OPD 

ErrorB2 คําส่ังที่นับจํานวน Error B2 ใน OPD 

ErrorB3 คําส่ังที่นับจํานวน Error B3 ใน OPD 

ErrorB4 คําส่ังที่นับจํานวน Error B4 ใน OPD 

ErrorB5 คําส่ังที่นับจํานวน Error B5 ใน OPD 

ErrorB6 คําส่ังที่นับจํานวน Error B6 ใน OPD 

ErrorB8 คําส่ังที่นับจํานวน Error B8 ใน OPD 

ErrorB9 คําส่ังที่นับจํานวน Error B9 ใน OPD 

ErrorB10 คําส่ังที่นับจํานวน Error B10 ใน OPD 

ErrorC1 คําส่ังที่นับจํานวน Error C1 ใน OPD 

TotalError (ErrorA1+ErrorA2+ErrorB1+ErrorB2+ErrorB3+ErrorB4 
+ErrorB5+ErrorB6+ErrorB8+ErrorB9+ErrorB10+ErrorC1)/
จาํนวนผูป่้วย  

  
9. กดปุม Finish จะไดตารางรายงานที่แยกตามอําเภอ ดังภาพดานลาง 
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10. ตารางน้ีสามารถขยายรายละเอียดเพื่อแสดงสถานพยาบาลในแตละอําเภอได โดยการคลิกขวาที่ปุม

เครื่องหมาย + ในคอลัมนแรก แลวเลือก Expand All ดังภาพดานลาง 

 
 

 
 

 
 
 
เราสามารถสงขอมูลจากตารางน้ี ไปสู Excel ไดโดยการกดปุม XL ดานบนขวาของตาราง 

 

ฝกปฎิบัติบทท่ี 8 : สรางตารางเพ่ิมเติมเพ่ือแสดง 

 
8.3 รายงานความผิดพลาดการใหรหัส ICD ในผูปวย IPD จําแนกตามอําเภอ 
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บทที่ 9  
การปรับแตงคลังขอมูลใหมีประสิทธิภาพ ใชงานงาย  

 
คลังขอมูลจะเปนแหลงขอมูลหลักที่เราสามารถใชในการใหบริการขอมูลภายในหรือภายนอกหนวยงาน จึงควร

ปรับแตงคลังขอมูลใหสวยงาม มีประสิทธิภาพ และใชงานงาย เพื่อใหผูใชเกิดความสะดวก และสามารถใชคลังขอมูล

คนหา แสดงขอมูลทีต่องการไดอยางรวดเร็ว ตรงตามความตองการ 

การปรับแตงคลังขอมูลใหมีประสิทธิภาพและใชงานงาย ทําไดโดยขั้นตอนตางๆดังตอไปน้ี 

 

การจัดโครงสรางและสวนแสดงผลของคลังขอมูล 
คลังขอมูลมักจะมีเน้ือหาจํานวนมาก จึงควรจัดโครงสรางเปนหลายสวน ไดแก สวนแนะนําคลังขอมูล สวน

แสดงผล และสวนอางอิง เราสามารถใช Qlikview สรางสวนตางๆของคลังขอมูลไดดังตอไปน้ี 

 

การเพ่ิมเติมและจัดตําแหนง Sheet 
การเพิ่ม Sheet ในคลังขอมูล ทําไดโดยการเรียกคําส่ังจากเมนู Layout => Add Sheet… ดังน้ี 

 
 
 
 
 
 
 
 
 
 
 
Sheet ใหมที่เพิ่มขึ้นมาน้ี เราสามารถปรับแตงได โดยการคลิกขวาที่ ตําแหนงหัวของSheet จะปรากฎเมนู

ขึ้นมา ใหเลือก Sheet Properties… ดังน้ี 
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เราสามารถปรับแตงคุณสมบัติของ Sheet ไดในกรอบโตตอบน้ี เชน ตั้งชื่อ Sheet ใหม ปรับเปล่ียน 

Background ปรับการแสดงลักษณะสีตางๆ  

เราสามารถปรับตําแหนง Sheet ใหเล่ือนไปทางซายหรือทางขวาได โดยใชคําส่ัง จาก เมนู Layout => 

Promote Sheet (เล่ือนไปทางซาย) หรือ Layout => Demote Sheet (เล่ือนไปทางขวา) ดังภาพตอไปน้ี 

 
 
 
 
 
 
 
 
 
 
 
 

ฝกฝนเพิ่มเติม 

ลองสราง Sheet แนะนําคลังขอมูล กําหนดตําแหนงเปน Sheet แรกสุด และ Sheet เก่ียวกับคลังขอมูล 

กําหนดไวเปน Sheet หลังสุด 
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การสราง Sheet แนะนําคลังขอมลู 

หนาแรกของคลังขอมูล ควรเปนหนาที่มีขอความแนะนําคลังขอมูล ความเปนมา วัตถุประสงค และขอความ

อ่ืนๆที่ตองการแนะนํา อาจมีรูปภาพ ตราสัญลักษณของหนวยงาน เพื่อใหมีลักษณะนาเชื่อถือ เราสามารถใสขอความใน 

Sheet แนะนําคลังขอมูลดังน้ี 

ใสกรอบขอความโดย เลือก เมนู Object => New Sheet Object => Text Object… หรือกด

ปุม      

ใน  Toolbar ดังน้ี 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
เราสามารถใสขอความ แนะนําไดใน Text Object ดังภาพตอไปน้ี 
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ฝกฝนเพิ่มเติม 

ลองเพิ่มขอความแนะนําคลังขอมูล ปรับแตง ขนาดและสีตัวอักษร พื้นหลัง และการจัดตําแหนงตางๆ ตาม

ตองการ 

 

การใสรูปใน Sheet คลังขอมูล 

การใสรูปทําโดย เลือก เมนู Object => New Sheet Object => Text Object… หรือกดปุม      

บน Toolbar ดังภาพตอไปน้ี 

 
 
ในหัวขอ Background เลือกรายการ Image แลวกดปุม Change เพื่อเลือก File รูปภาพที่ตองการ 

แลวกดปุม OK 
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จะไดรูปที่ตองการ สามารถปรับแตงคุณสมบัติตางๆได โดยคลิกขวาเลือก Properties 

 

การเพ่ิมปุมกดใน Sheet คลังขอมูล 

เราสามารถใสปุมกด ที่กําหนดใหเกิด action ตางๆ ในคลังขอมูลของเราได  

การใสปุมกดทําโดย เลือก เมนู Object => New Sheet Object => Text Object… หรือกด

ปุม        บน Toolbar ดังภาพตอไปน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
เราจะลองสรางปุมที่กดแลว จะเปล่ียน Sheet ไปหนาถัดไป โดยพิมพขอความในชอง Text วา “ไปหนา

ถัดไป” ดังน้ี 
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กดปุม OK จะไดปุมขึ้นมา 1 ปุม ดังน้ี 

 
 
 

กําหนดใหปุมน้ีมี action โดย คลิกขวาเรียกเมนู Properties… แลวปรับแตงใน tab action โดยกด

ปุม Add ดังน้ี 

 

 
 
เลือก Action Type : เปน Layout เลือก Action เปน Activate Next Sheet แลวกดปุม OK 

สองครั้ง เราจะไดปุมมี action เม่ือกดแลวจะเปล่ียนหนา Sheet เปนหนาถัดไป 

 
ฝกฝนเพิ่มเติม 

ลองเพิ่มปุม “กลับไปหนากอน” หรือ ปุมอ่ืนๆตามตองการ 

 

การ Copy Sheet  
บางครั้งเราตองการให Sheet มีลักษณะคลายๆกัน หลาย Sheet ถาเราไมตองการสราง Object ซํ้าๆกัน

ในแตละ Sheet เราก็สามารถ Copy Sheet ไปไดเลย  
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การ Copy Sheet ทําโดย คลิกขวาที่ Sheet แลวเลือก Copy Sheet ดังน้ี 

 
 
 

 
 

 
 

 
 
 
 
 

การปรับเปลีย่นรูปแบบของกราฟ 
กราฟหลายแบบที่มีลักษณะการแสดงขอมูลคลายๆกัน สามารถปรับเปล่ียนรูปแบบกลับไปกลับมาได เชน 

ระหวางกราฟแทงกับกราฟวงกลม 

การปรับเปล่ียนรูปแบบของกราฟ ทําไดโดยคลิกขวา เลือก Properties… Tab General ดังภาพ 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ในที่น้ีตองการเปล่ียน กราฟแทงเปนกราฟวงกลม จึงเลือกภาพกราฟวงกลม แลวกดปุม OK 
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กราฟแทงเปล่ียนเปนกราฟวงกลมตามตองการ หรือหากตองการกําหนดการแสดงผลภายในกราฟใหมีปุมปรับ

การแสดงผลไดหลายแบบ สามารถกําหนดจาก Tab General ในชอง Fast Type Change Allow Type 

ไดเลยดังภาพ 

 

 
 
 
 
 
 
 
 
ในภาพน้ี กําหนดใหสามารถเปล่ียนรูปแบบกราฟไดเปน 3 แบบ คือ กราฟแทง (Bar Chart) กราฟเสน 

(Line Chart) และ กราฟวงกลม (Pie Chart) เม่ือกดปุม OK จะพบวาตรงกรอบดานบนขวาของกราฟจะมีปุมที่

ใชปรับลักษณะ ถากดปุมน้ัน กราฟจะเปล่ียนลักษณะไปไดเรื่อยๆ 

 
 

 
 
 
 
 
 
 

ปุ่ มทีใช้ปรับลกัษณะของกราฟ 
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บทท่ี 10  

การเพิม่เติมขอมูลเขาสูคลังขอมูลใหทันสมัยอยางตอเนื่อง 
คลังขอมูลที่จัดทําขึ้นสําเร็จแลว จะใชไดดีอยางตอเน่ืองได ก็ตองมีการเพิ่มเติมขอมูลใหมเขาไปใหทันสมัยอยู

ตลอดเวลา การเพิ่มเติมขอมูลเขาสูคลังขอมูลโดยใชโปรแกรม Qlikview น้ัน ทําไดโดยงาย โดยมีขั้นตอนที่สําคัญคือ 

1. เพิ่มเติมขอมูลเขาสูแหลงขอมูลที่เชื่อมตอกับคลังขอมูล เชน ถาแหลงขอมูลมาจาก ไฟล Excel ใด ก็ตอง

บันทึกขอมูลใหมเขาสูไฟลน้ันเสียกอน 

2. ใชคําส่ัง Reload นําเขาขอมูล ตามภาพดังตอไปน้ี 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
เม่ือเลือกเมนู File => Reload จะปรากฏหนาจอแสดงการ Reload ขอมูลดังน้ี 
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การ Reload อาจใชเวลามากถาปริมาณขอมูลมีมาก โดย Qlikview จะ Reload ขอมูลใหมทั้งชุด มิใช 

Reload เฉพาะขอมูลใหมที่เปล่ียนแปลง 
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